Bug 506797 - virt-manager drops vifname
virt-manager drops vifname
Status: CLOSED DUPLICATE of bug 465593
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.3
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 13:11 EDT by Brian Buchanan
Modified: 2009-12-14 16:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 13:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Buchanan 2009-06-18 13:11:33 EDT
Description of problem:
Manually added vif option vifname to a xen domu config file is truncated by virt-manager

Version-Release number of selected component (if applicable):
0.5.3

How reproducible:
100%
Create a Virtual Machine. Close virt-manager.  Manually edit the /etc/xen/xxx config file, adding the option vifname to the nic definition on the vif line.  Start the vm with `xm create` and check with ifconfig in dom0 that the specified device name is used.  Now use virt-manager to configure an additional disk file and note that the vifname option has been removed.

Steps to Reproduce:
1. Create a Virtual Machine with virt-manager
2. Manually add the vifname option to the NIC defintion on the vif line in the config file
3. Add another storage device via virt-manager
  
Actual results:
vifname has been removed from the vif line in config file.

Expected results:
vifname should be preserved.

Additional info:
virt-manager has no way of setting vifname, so this must be done manually.
Comment 1 Cole Robinson 2009-06-18 13:30:48 EDT
The issue is that libvirt probably didn't support the vifname parameter, so when converting the xm file to XML and back, it loses the changes you made. This may be supported in the libvirt version pending for 5.4.

Reassigning to libvirt.
Comment 2 Daniel Berrange 2009-06-18 13:56:56 EDT

*** This bug has been marked as a duplicate of bug 465593 ***

Note You need to log in before you can comment on or make changes to this bug.