Bug 506824 - VTK overrides cmake ccmake setting
VTK overrides cmake ccmake setting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 15:23 EDT by Per Inge Mathisen
Modified: 2009-08-10 17:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.4.2-33.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 17:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Inge Mathisen 2009-06-18 15:23:28 EDT
Description of problem:

In VTKBuildSettings.cmake the define CMAKE_BUILD_SETTING_CXX_COMPILER is hard-coded to "/usr/bin/c++" which will make it override any ccmake settings from CMake and generate warnings when CMake is run. Please do not set this define in your builds.

Version-Release number of selected component (if applicable):
vtk-5.2.1-1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Build any CMake project with VTK
2. For example, this simple CMakeLists.txt file:

   cmake_minimum_required(VERSION 2.6)
   project( test )
   find_package(VTK REQUIRED)
   include(${VTK_USE_FILE})
  
Actual results:
-- Detecting CXX compiler ABI info - done
Warning: CMake is forcing CMAKE_CXX_COMPILER to "/usr/bin/c++" to match that imported from VTK.  This is required because C++ projects must use the same compiler.  If this message appears for more than one imported project, you have conflicting C++ compilers and will have to re-build one of those projects. Was set to /usr/lib64/ccache/c++

Expected results:
No warning. ccmake is used for build.

Additional info:
The worry noted by CMake above is entirely unfounded, since ccmake is not a different C++ compiler than /usr/bin/c++, just a build cache program
Comment 1 Axel Thimm 2009-07-23 06:14:21 EDT
(In reply to comment #0)
> In VTKBuildSettings.cmake the define CMAKE_BUILD_SETTING_CXX_COMPILER is
> hard-coded to "/usr/bin/c++" which will make it override any ccmake settings
> from CMake and generate warnings when CMake is run. Please do not set this
> define in your builds.

> The worry noted by CMake above is entirely unfounded, since ccmake is not a
> different C++ compiler than /usr/bin/c++, just a build cache program  

That is actually an old feature from CMake, which you can turn off with 

set(CMAKE_OVERRIDE_COMPILER_MISMATCH 1)

VTK needs to migrate to the latest CMake version to not need this anymore, but as of the version you used it obviously hadn't yet. There is 5.4.2 hitting updates-testing, and it would be interesting to add whether this fixes your issue.

Can you please check against 5.4.2 and report back? Thanks!
Comment 2 Fedora Update System 2009-07-23 06:24:33 EDT
vtk-5.4.2-33.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vtk-5.4.2-33.fc11
Comment 3 Fedora Update System 2009-07-23 06:24:55 EDT
vtk-5.4.2-33.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/vtk-5.4.2-33.fc10
Comment 4 Per Inge Mathisen 2009-07-23 08:13:48 EDT
"Can you please check against 5.4.2 and report back? Thanks!"

I tested the new RPMs and they still seem to have the same issue here. I added the cmake override, and that worked, though. The other bug I reported (qt3 dependency) seems to have been fixed fine. Thank you.
Comment 5 Axel Thimm 2009-07-23 11:02:24 EDT
Ok, thanks! I'll remove the bug from the list of fixed bugs in the update (although bodhi doesn't let me currently do that - should this bug be inadvertently closed please reopen).

BTW I forgot to add the URL of where this bug has been discussed:

http://www.cmake.org/Bug/view.php?id=7745
Comment 6 Fedora Update System 2009-07-23 15:03:24 EDT
vtk-5.4.2-33.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7940
Comment 7 Fedora Update System 2009-07-23 15:09:56 EDT
vtk-5.4.2-33.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7958
Comment 8 Fedora Update System 2009-08-01 19:52:56 EDT
vtk-5.4.2-33.fc10, vtkdata-5.4.2-13.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vtk vtkdata'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-7940
Comment 9 Fedora Update System 2009-08-01 20:02:45 EDT
vtk-5.4.2-33.fc11, vtkdata-5.4.2-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vtk vtkdata'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7958
Comment 10 Fedora Update System 2009-08-10 17:43:06 EDT
vtk-5.4.2-33.fc10, vtkdata-5.4.2-13.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-08-10 17:44:12 EDT
vtk-5.4.2-33.fc11, vtkdata-5.4.2-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.