This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506828 - tor-lsb has too much dependencies
tor-lsb has too much dependencies
Status: CLOSED DUPLICATE of bug 472630
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 15:42 EDT by Henning Norén
Modified: 2009-06-18 18:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 18:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henning Norén 2009-06-18 15:42:12 EDT
Description of problem:
tor-core depends on package fedora-usermgmt which drags in a lot of other dependencies. This prevents you from keeping a minial server running a tor node.

Version-Release number of selected component (if applicable):
tor-core.x86_64 0:0.2.0.34-3.fc11
fedora-usermgmt-core.noarch 0:0.10-3.fc11

How reproducible:
Always

Steps to Reproduce:
1. Install minimal fedora system
2. yum install tor-core

  
Actual results:

$ yum install tor-core
Loaded plugins: presto
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package tor-core.x86_64 0:0.2.0.34-3.fc11 set to be updated
--> Processing Dependency: fedora-usermgmt for package: tor-core-0.2.0.34-3.fc11.x86_64
--> Processing Dependency: init(tor) for package: tor-core-0.2.0.34-3.fc11.x86_64
--> Processing Dependency: fedora-usermgmt for package: tor-core-0.2.0.34-3.fc11.x86_64
--> Running transaction check
---> Package fedora-usermgmt.noarch 0:0.10-3.fc11 set to be updated
--> Processing Dependency: fedora-usermgmt-core = 0.10-3.fc11 for package: fedora-usermgmt-0.10-3.fc11.noarch
--> Processing Dependency: instance(fedora-usermgmt) for package: fedora-usermgmt-0.10-3.fc11.noarch
--> Processing Dependency: setup(fedora-usermgmt) for package: fedora-usermgmt-0.10-3.fc11.noarch
---> Package tor-lsb.noarch 0:0.2.0.34-3.fc11 set to be updated
--> Processing Dependency: lsb-core-noarch for package: tor-lsb-0.2.0.34-3.fc11.noarch
--> Processing Dependency: lsb-core-noarch for package: tor-lsb-0.2.0.34-3.fc11.noarch
--> Running transaction check
---> Package fedora-usermgmt-core.noarch 0:0.10-3.fc11 set to be updated
---> Package fedora-usermgmt-default-fedora-setup.noarch 0:0.10-3.fc11 set to be updated
---> Package fedora-usermgmt-shadow-utils.noarch 0:0.10-3.fc11 set to be updated
---> Package redhat-lsb.x86_64 0:3.2-3.fc11 set to be updated
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: /usr/bin/foomatic-rip for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: /usr/bin/gs for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtSql.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtGui.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libasound.so.2()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtNetwork.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtSvg.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtOpenGL.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libqt-mt.so.3()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtCore.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Processing Dependency: libQtXml.so.4()(64bit) for package: redhat-lsb-3.2-3.fc11.x86_64
--> Running transaction check
---> Package alsa-lib.x86_64 0:1.0.20-1.fc11 set to be updated
---> Package cups.x86_64 1:1.4-0.b2.18.fc11 set to be updated
--> Processing Dependency: poppler-utils for package: 1:cups-1.4-0.b2.18.fc11.x86_64
---> Package foomatic.x86_64 0:4.0.0-2.fc11 set to be updated
---> Package ghostscript.x86_64 0:8.64-6.fc11 set to be updated
--> Processing Dependency: urw-fonts >= 1.1 for package: ghostscript-8.64-6.fc11.x86_64
--> Processing Dependency: ghostscript-fonts for package: ghostscript-8.64-6.fc11.x86_64
---> Package qt.x86_64 1:4.5.1-13.fc11 set to be updated
---> Package qt-x11.x86_64 1:4.5.1-13.fc11 set to be updated
--> Processing Dependency: libphonon.so.4()(64bit) for package: 1:qt-x11-4.5.1-13.fc11.x86_64
---> Package qt3.x86_64 0:3.3.8b-25.fc11 set to be updated
--> Running transaction check
---> Package ghostscript-fonts.noarch 0:5.50-20.fc11 set to be updated
---> Package phonon.x86_64 0:4.3.1-4.fc11 set to be updated
--> Processing Dependency: phonon-backend(x86-64) >= 4.3.1 for package: phonon-4.3.1-4.fc11.x86_64
---> Package poppler-utils.x86_64 0:0.10.5-1.fc11 set to be updated
--> Processing Dependency: poppler = 0.10.5-1.fc11 for package: poppler-utils-0.10.5-1.fc11.x86_64
--> Processing Dependency: libpoppler.so.4()(64bit) for package: poppler-utils-0.10.5-1.fc11.x86_64
---> Package urw-fonts.noarch 0:2.4-7.fc11 set to be updated
--> Running transaction check
---> Package phonon-backend-xine.x86_64 0:4.3.1-4.fc11 set to be updated
--> Processing Dependency: libxine.so.1()(64bit) for package: phonon-backend-xine-4.3.1-4.fc11.x86_64
---> Package poppler.x86_64 0:0.10.5-1.fc11 set to be updated
--> Running transaction check
---> Package xine-lib.x86_64 0:1.1.16.3-2.fc11 set to be updated
--> Processing Dependency: libtheora.so.0(libtheora.so.1.0)(64bit) for package: xine-lib-1.1.16.3-2.fc11.x86_64
--> Processing Dependency: libtheora.so.0()(64bit) for package: xine-lib-1.1.16.3-2.fc11.x86_64
--> Processing Dependency: libogg.so.0()(64bit) for package: xine-lib-1.1.16.3-2.fc11.x86_64
--> Processing Dependency: libFLAC.so.8()(64bit) for package: xine-lib-1.1.16.3-2.fc11.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: xine-lib-1.1.16.3-2.fc11.x86_64
--> Running transaction check
---> Package flac.x86_64 0:1.2.1-5.fc11 set to be updated
---> Package libogg.x86_64 2:1.1.3-11.fc11 set to be updated
---> Package libtheora.x86_64 1:1.0-3.fc11 set to be updated
---> Package libvorbis.x86_64 1:1.2.0-7.fc11 set to be updated
--> Finished Dependency Resolution


Expected results:
No extra dependencies except for possibly the init(tor).

Additional info:
None
Comment 1 Enrico Scholz 2009-06-18 18:31:44 EDT
it is not due to fedora-usermgmt, but caused by improper redhat-lsb packaging.

You can avoid the excessive dependencies by installing tor-upstart instead of tor-lsb.

*** This bug has been marked as a duplicate of bug 472630 ***

Note You need to log in before you can comment on or make changes to this bug.