Bug 506847 - gnome-screensaver does not work with xfce
gnome-screensaver does not work with xfce
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 17:18 EDT by Peter Backes
Modified: 2015-01-14 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 15:13:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 592093 None None None Never
Xfce 5927 None None None Never

  None (edit)
Description Peter Backes 2009-06-18 17:18:37 EDT
Description of problem:
gnome-screensaver does not work as desired on xfce sessions; it simply does not blank/lock the screen. This happens since I yum upgraded from F10 to F11.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.26.1-2.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. Login to xfce4 session
2. Preferences => Screensaver
3. choose 1 minute as "Regard computer as idle after", make sure "Activate screensaver when compute is idle" and "Lock screen when screensaver is active" are enabled both
4. Close
5. Wait more than 60 seconds

Actual results:
Nothing happens

Expected results:
Screen is blanked and locked

Additional info:
It works fine under GNOME. Further, even on a xfce session, gnome-screensaver-command --lock works just fine. And, even on a xfce session, the display seems to go to sleep after some time (but not 1 minute); however, after it has done so, no password is requested on activity.

This bug is different from #505915, because it describes a situation (without mentioning session type) where only locking fails and blanking works fine.

I can reproduce it even with a newly created user that didn't exist yet before the upgrade.
Comment 1 LunaSilverMoon 2009-07-18 09:10:39 EDT
This is also true on a clean install of Fedora 11 xfce spin.
Comment 2 Peter Backes 2009-11-18 21:37:48 EST
problem persists in f12
Comment 3 Olivier Mehani 2011-05-17 10:53:38 EDT
Hi,

As mentionned in the Gnome Bugzilla [0], I've had the same problem with my simple Fvwm-based environment and ended up writing a Python script which impersonates  the Gnome SessionManager, and does the XIDLE detection for Gnome ScreenSaver. It's available from [1], and the code is documented at [2].

[0] https://bugzilla.gnome.org/show_bug.cgi?id=592093
[1] https://scm.narf.ssji.net/svn/shtrom/browser/default-env/bin/SessionManager.py
[2] http://www.narf.ssji.net/~shtrom/wiki/projets/gnomescreensavernosession

Note You need to log in before you can comment on or make changes to this bug.