Bug 506929 - Add system_reboot to qemu
Add system_reboot to qemu
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
high Severity medium
: ---
: ---
Assigned To: Markus Armbruster
Lawrence Lim
:
Depends On:
Blocks: 495479
  Show dependency treegraph
 
Reported: 2009-06-19 07:12 EDT by Daniel Berrange
Modified: 2014-03-25 20:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 503184
Environment:
Last Closed: 2009-12-14 09:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2009-06-19 07:12:26 EDT
+++ This bug was initially created as a clone of Bug #503184 +++

Description of problem:
libvirt uses a 'system_shutdown' command for a controlled guest shutdown (ie run initscript to shutdown, and then poweroff).

We would like to have the same functionality available, but doing a restart instead of poweroff. 

ie this patch adding a system_reboot command

http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00450.html

Version-Release number of selected component (if applicable):
qemu-0.10.0

How reproducible:
Always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

--- Additional comment from markmc@redhat.com on 2009-06-03 12:45:55 EDT ---

We should ping upstream about this, hopefully it should be in 0.11

v2 of patch is here:

http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00658.html

--- Additional comment from fedora-triage-list@redhat.com on 2009-06-09 12:47:21 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 1 Mark McLoughlin 2009-07-09 03:32:19 EDT
This isn't reasonable for 5.4 since it isn't agreed upstream yet:

  http://lists.gnu.org/archive/html/qemu-devel/2009-07/threads.html#00507

Moving to 5.5
Comment 2 Markus Armbruster 2009-12-14 09:00:44 EST
Punted up to libvirt (bug #495479), because upstream qemu rejected the feature.  See bug#495479 comment#3 for details.

Note You need to log in before you can comment on or make changes to this bug.