Bug 50694 - rescue mode fails to mount sysimage from scsi disc
rescue mode fails to mount sysimage from scsi disc
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 06:32 EDT by Gerald Teschl
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 15:52:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-08-02 06:32:52 EDT
I just used "linux rescue" on a box with one single scsi hard drive
/dev/sda with two partition sda1 -> linux and sda2 -> swap and it
claimed that I don't have any linux partitions!?

The scsi driver was loaded and just using "mkdir /mnt/sysimage; mount
/dev/sda1 /mnt/sysimage" worked fine.

Please crate at least the mount point "/mnt/sysimage" even if no
partitions are found or if the user chooses not to look for them.
This does not hurt and it saves some typing.
Comment 1 Glen Foster 2001-08-02 17:45:35 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 2 Jeremy Katz 2001-08-08 17:29:35 EDT
Well, if you just do `mount /dev/sda1 /mnt/sysimage` the mountpoint will get
automagically created if it doesn't exist.

Was the filesystem unmounted cleanly before booting into rescue mode?
Comment 3 Michael Fulbright 2001-08-08 22:19:34 EDT
Was anything installed on the Linux partition?
Comment 4 Gerald Teschl 2001-08-09 04:50:30 EDT
The mountpoint might be crated but you can't use "tab";-) Moreover, if you
mistype it your path won't be correct.

No the fs was clean and the linux partition contained a fresh install
(unfortunately anaconda failed to install lilo correctly....).
Comment 5 Gerald Teschl 2001-08-09 04:52:35 EDT
BTW, I just noted that if you have to drives hda and hdb which both
contain linux installations it will mount the one from hdb rather than
the one from hda. Shouldn't it check hd{a,b,c,d} in this order? This
seems more resonable to me.
Comment 6 Michael Fulbright 2001-08-09 17:55:13 EDT
I would have expected if there are multiple linux filesystems present that
contain a 'etc/fstab' file that you would be prompted for the correct partition
to mount. I will test this.
Comment 7 Michael Fulbright 2001-09-05 16:21:03 EDT
I have not seen any problems detecting and asking the user which of multiple
installs to rescue/upgrade.  Have you tried this with RC2?
Comment 8 Brent Fox 2001-09-17 10:55:11 EDT
Any more info here?
Comment 9 Brent Fox 2001-09-27 14:50:50 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.