Bug 506950 - Red Hat Channels menu item present
Red Hat Channels menu item present
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity low
: ---
: ---
Assigned To: Devan Goodwin
Red Hat Satellite QA List
:
Depends On:
Blocks: space08
  Show dependency treegraph
 
Reported: 2009-06-19 09:35 EDT by Tomas Lestach
Modified: 2010-02-16 08:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 07:56:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-06-19 09:35:46 EDT
Description of problem:
There's a menu item "Red Hat Channels" on the WEBUI.
Because it isn't possible to activate Spacewalk server against Hosted and to sync Red Hat channels, Spacewalk can never manage a Red hat channel.
The menu item is redundant.

Version-Release number of selected component (if applicable):
Spacewalk 0.5

How reproducible:
always

Steps to Reproduce:
1. Login into the WEBUI and navigate your browser to:
https://<your-spacewalk-server>/rhn/software/channels/All.do
  
Actual results:
a.) The "Software Channels" menu on the left displays a menu item "Red Hat Channels".

b.) Also the 1st sentence on the web page is:
"The software channels listed below are all of the channels that your organization is entitled to and are currently supported by Red Hat."

Expected results:
a.) No menu item "Red Hat Channels".

b.) Because Spacewalk server can manage only custom channels, there are no channels supported by Red Hat. The sentence shall be fixed.
Comment 1 Justin Sherrill 2010-01-27 18:44:52 EST
Put an acl around the "Red Hat Channels" tab on the left and at the top sub menu.

That text saying supported by RedHat doesn't seem to still be there. Probably was previously removed.

Fixed in master:2a215ec3108e53f6b977bb705f6152a0cc50dbc1
Comment 2 Michael Mráka 2010-02-04 05:30:32 EST
Released in spacewalk-java-0.8.9-1.
Comment 3 Michael Mráka 2010-02-16 08:00:01 EST
Spacewalk 0.8 has been released

Note You need to log in before you can comment on or make changes to this bug.