Bug 506957 - #BPY blender scripts are considered as wrong-script-interpreter by rpmlint
#BPY blender scripts are considered as wrong-script-interpreter by rpmlint
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 10:32 EDT by Nicolas Chauvet (kwizart)
Modified: 2009-07-16 03:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.90-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 01:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-06-19 10:32:28 EDT
Description of problem: rpmlint blender (taken from 2.49a-1.fc12)
blender.x86_64: E: wrong-script-interpreter /usr/share/blender/scripts/uvcalc_smart_project.py "BPY"
blender.x86_64: E: non-executable-script /usr/share/blender/scripts/uvcalc_smart_project.py 0644


Version-Release number of selected component (if applicable):
rpmlint-0.87-1.fc10.noarch

  
Actual results:
For each BPY file packaged, two errors are given.


Expected results:
rpmlint should know "Blender PYthon" scripts and don't consider them abnormal.

Additional info:
There is multiple locations where to expect BPY file with .py extension.
If provided with the blender package, they can be in /usr/share/blender/scripts
If provided with an external (architecture dependant) module such as yafaray-blender, they can be in %{_libdir}/blender/scripts

(In the current situation, those script are runned from the user directory :
~/.blender/scripts)

Those scripts aren't expected to be set executable. (as any files from python_sitelib).
Comment 1 Fedora Update System 2009-06-21 18:01:05 EDT
rpmlint-0.89-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpmlint-0.89-1.fc11
Comment 2 Fedora Update System 2009-06-21 18:02:21 EDT
rpmlint-0.89-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmlint-0.89-1.fc10
Comment 3 Nicolas Chauvet (kwizart) 2009-06-25 11:06:45 EDT
This problem doesn't seems to be solved with the above update !
Comment 4 Ville Skyttä 2009-06-25 13:54:15 EDT
Details, please (for example the output of rpm -q rpmlint, rpm -V rpmlint, cat ~/.rpmlintrc, cat ~/.config/rpmlint, ls /etc/rpmlint/).   It is fixed for me:

$ rpm -q rpmlint
rpmlint-0.87-1.fc10.noarch

$ rpmlint blender-2.48a-5.fc10.x86_64.rpm | grep '\(non-executable-script\|wrong-script-interpreter\)' | wc -l
282

$ sudo rpm -U http://kojipkgs.fedoraproject.org/packages/rpmlint/0.89/1.fc10/noarch/rpmlint-0.89-1.fc10.noarch.rpm

$ rpm -q rpmlint
rpmlint-0.89-1.fc10.noarch

$ rpmlint blender-2.48a-5.fc10.x86_64.rpm | grep '\(non-executable-script\|wrong-script-interpreter\)'
blender.x86_64: E: non-executable-script /usr/share/blender/scripts/bpymodules/blend2renderinfo.py 0644 /usr/bin/python
Comment 5 Nicolas Chauvet (kwizart) 2009-06-26 03:08:20 EDT
oups, sorry: yes it works, with rpmlint-0.89-1, but it is still not in updates-testing for F-11 for some reason.
Comment 6 Fedora Update System 2009-06-29 11:46:28 EDT
rpmlint-0.90-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpmlint-0.90-1.fc11
Comment 7 Fedora Update System 2009-06-29 11:48:45 EDT
rpmlint-0.90-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpmlint-0.90-1.fc10
Comment 8 Fedora Update System 2009-07-16 03:27:04 EDT
rpmlint-0.90-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-07-16 03:29:42 EDT
rpmlint-0.90-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.