Bug 506959 - Few minor systemtap-testsuite issues
Few minor systemtap-testsuite issues
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: systemtap (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Frank Ch. Eigler
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 10:54 EDT by Petr Muller
Modified: 2016-09-19 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 05:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2009-06-19 10:54:40 EDT
Description of problem:
Few of the testcases in the testsuite have minor issues which generate noise when doing a testsuite run.

1) buildok/thirtyone.stp is not an executable, but it is treated as one when buildok.exp runs. Thus, bogus 'Permission denied' messages appear when running. Similar issue was fixed in the last iteration, but this testcase was brought in with some new fix

2) systemtap.base/sdt.exp has bogus failures when doing simple 'make installcheck', because compilation of std.c fails due to '#include "sdt.h"'. This header is only found when running in the tree, not when running the installcheck.

3) systemtap.base/crash.exp is trying to do 'spawn stap $srcdir/$subdir/testlog.stp', which fails because the file is simply not there:
[root@x86-64-v00 testsuite]# find . -name testlog.stp

Version-Release number of selected component (if applicable):
# rpm -q systemtap-testsuite
systemtap-testsuite-0.9.7-5.el5

How reproducible:
Always

Steps to Reproduce:
1. all three issues manifest when doing 'make installcheck'

Actual results:
bogus failures

Expected results:
tests do their job
Comment 1 Frank Ch. Eigler 2009-12-01 09:59:16 EST
already fixed upstream
Comment 6 errata-xmlrpc 2010-03-30 05:06:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0308.html

Note You need to log in before you can comment on or make changes to this bug.