Bug 506978 - canberra-gtk-play crashes on every start of GNOME, no sound on HP 2133
canberra-gtk-play crashes on every start of GNOME, no sound on HP 2133
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
11
i386 Linux
high Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-06-19 12:14 EDT by Lebenskuenstler
Modified: 2009-09-28 23:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 23:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
crash report canberra-gtk-play (232.79 KB, text/plain)
2009-06-19 12:14 EDT, Lebenskuenstler
no flags Details
backtrace (10.69 KB, text/plain)
2009-08-22 14:08 EDT, E.Patton
no flags Details
canberra-gtk-play-bugreport.txt (1) (227.34 KB, text/plain)
2009-09-04 07:34 EDT, Robert Scheck
no flags Details
canberra-gtk-play-bugreport.txt (2) (227.35 KB, text/plain)
2009-09-04 07:35 EDT, Robert Scheck
no flags Details
Traceback on latest updates (10.53 KB, text/plain)
2009-09-06 08:42 EDT, E.Patton
no flags Details
Equivalent crash in KDE (5.60 KB, text/plain)
2009-09-06 10:08 EDT, E.Patton
no flags Details
Output from lspci (1.61 KB, text/plain)
2009-09-08 19:28 EDT, William Makowski
no flags Details

  None (edit)
Description Lebenskuenstler 2009-06-19 12:14:38 EDT
Created attachment 348682 [details]
crash report canberra-gtk-play

Description of problem:

Everytime I log in into GNOME, canberra-gtk-play crashes. Report attached.

In consequence there is no sound on HP 2133, EVERY application which tries to play sound will crash, too!

An exerpt from /var/log/messages:

ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32
ALSA sound/pci/hda/hda_intel.c:1101: Too big adjustment 32: adj=128, bytes=128, size=4096, periods=32

Must this be reported against pulse?

Version-Release number of selected component (if applicable):


How reproducible:

log in into GNOME, sound does also not work in KDE

Steps to Reproduce:
1. log in into GNOME
2.
3.
  
Actual results:

crashs, crashs, crashs (sigh)
Comment 1 Lebenskuenstler 2009-06-19 18:44:06 EDT
One more thing to note:

Neither with the released live cd of GNOME nor KDE this happens.
Comment 2 Lennart Poettering 2009-06-30 16:58:52 EDT
Any chance you can get me a backtrace on this crash?
Comment 3 Lennart Poettering 2009-07-28 11:15:11 EDT
Closing due to lack of response.
Comment 4 E.Patton 2009-08-22 14:08:19 EDT
Created attachment 358316 [details]
backtrace

Requested backtrace.

Could this bug be re-opened? No sound under either Gnome or KDE using any application.
Comment 5 William Makowski 2009-08-26 11:24:22 EDT
I too would like to see this bug reopened since more than one person is encountering it. See bug 516092 - https://bugzilla.redhat.com/show_bug.cgi?id=516092

Version-Release number of selected component (if applicable):
libcanberra-0.12-1.fc11.i586

smolt UUID:
pub_cde052f6-5d59-4b82-9272-5c3c69a84b23
Comment 6 Robert Scheck 2009-09-04 07:33:16 EDT
Well, thats reproducible here each time. Attaching backtraces soon.
Comment 7 Robert Scheck 2009-09-04 07:34:26 EDT
Created attachment 359796 [details]
canberra-gtk-play-bugreport.txt (1)
Comment 8 Robert Scheck 2009-09-04 07:35:07 EDT
Created attachment 359797 [details]
canberra-gtk-play-bugreport.txt (2)
Comment 9 Robert Scheck 2009-09-04 07:36:44 EDT
Please fix this annoying bug very soon - you've everything you need...
Comment 10 Robert Scheck 2009-09-04 08:29:37 EDT
Adding Jan, as he's able to reproduce this bug all the time at a HP 2133.
Comment 11 Lennart Poettering 2009-09-04 09:58:58 EDT
This is probably breakage in the PRIO_INHERIT mutexes on some kernels.

Which kernel are you running? Have you upgraded to the newest F-11 kernel?
Comment 12 Jan Theofel 2009-09-04 10:45:45 EDT
Here is the output of my uname command:
2.6.29.6-217.2.16.fc11.i686.PAE #1 SMP Mon Aug 24 17:16:21 EDT 2009 i686 i686 i386 GNU/Linux

Latest updates are installed using "yum update". No kernel updates were found since the network installation this morning.
Comment 13 E.Patton 2009-09-06 08:42:46 EDT
Created attachment 359906 [details]
Traceback on latest updates

uname -va gives
Linux elinu01 2.6.29.6-217.2.16.fc11.i686.PAE #1 SMP Mon Aug 24 17:16:21 EDT 2009 i686 i686 i386 GNU/Linux
Comment 14 E.Patton 2009-09-06 10:08:46 EDT
Created attachment 359911 [details]
Equivalent crash in KDE

KDE also seems to fail at a similar point. Attached is the Knotify crash report. KDE also lacks sound which would suggest some underlying common error rather than just in canberra-gtk-play.

System configuration and kernel is the same as reported in comment #13
Comment 15 Lennart Poettering 2009-09-07 12:06:06 EDT
That KDE issue appears to be unrelated. Please file an independant bug against xine.

pthread_mutex_unlock() failing really smells like another iteration of bug 492838 or something related to that.

Would be good if someone could check if this is reproducible if PRIO_INHERIT is not used for the mutexes of PA. Anyone up to this? Would just mean to rebuild PA with the pthread_mutexattr_setprotocol(&attr, PTHREAD_PRIO_INHERIT) line commented in src/pulsecore/threaded-mainloop.c.

This is 32bit only iiuc?
Comment 16 William Makowski 2009-09-07 16:08:38 EDT
I just updated to the latest everything and this problem seems to have gone away. Looks like there was a new version of pulseaudio in with the updates. Can anyone else confirm?
Comment 17 E.Patton 2009-09-08 16:41:22 EDT
Versions before latest update:

alsa-plugins-pulseaudio.i586      1.0.20-2.fc11               installed
kde-settings-pulseaudio.noarch    4.2-12                      @updates
pulseaudio.i586                   0.9.15-14.fc11              installed
pulseaudio-debuginfo.i586         0.9.15-14.fc11              @updates-debuginfo
pulseaudio-libs.i586              0.9.15-14.fc11              installed
pulseaudio-libs-glib2.i586        0.9.15-14.fc11              installed
pulseaudio-module-bluetooth.i586  0.9.15-14.fc11              installed
pulseaudio-module-gconf.i586      0.9.15-14.fc11              installed
pulseaudio-module-x11.i586        0.9.15-14.fc11              installed
pulseaudio-utils.i586             0.9.15-14.fc11              installed
xine-lib-pulseaudio.i586          1.1.16.3-2.fc11             installed

Versions after latest update:

kernel-PAE.i686                           2.6.30.5-43.fc11               updates
kernel-PAE-devel.i686                     2.6.30.5-43.fc11               updates
kernel-firmware.noarch                    2.6.30.5-43.fc11               updates
kernel-headers.i586                       2.6.30.5-43.fc11               updates
pulseaudio.i586                           0.9.15-17.fc11                 updates
pulseaudio-libs.i586                      0.9.15-17.fc11                 updates
pulseaudio-libs-glib2.i586                0.9.15-17.fc11                 updates
pulseaudio-module-bluetooth.i586          0.9.15-17.fc11                 updates
pulseaudio-module-gconf.i586              0.9.15-17.fc11                 updates
pulseaudio-module-x11.i586                0.9.15-17.fc11                 updates
pulseaudio-utils.i586                     0.9.15-17.fc11                 updates


Opening sounds work but break up and are distorted. The canberra-gtk-play crash has gone. The break up and distortion are not heard with players.

Sound players e.g. Amarok now play.

I don't know if it is a hardware issue with the HP 2133 that I have but the sound is only working on the RH channel.

The KDE issue referenced in comment #14 has also gone following the update.

The installation here is 32-bit.

Do you still want the PA rebuild done? Willing to give it a go if still needed.
Comment 18 William Makowski 2009-09-08 19:28:35 EDT
Created attachment 360142 [details]
Output from lspci

The initial problem of canberra-gtk-play crashing seems to be gone.

I don't have an HP 2133, but I do have a VIA pc2500 mainboard.  The HP 2133 also uses a VIA mainboard.  It might be safe to assume that the audio controller are similar in each of our systems.  I'm not an expert, but would be willing to bet that this is more of a problem with pulseaudio and the 00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60).

Should we close this bug and open one against pulseaudio?  I've attached the output from lspci on my system for comparison to an HP 2133.
Comment 19 Lennart Poettering 2009-09-28 23:24:19 EDT
Closing since the pthread_mutex_lock assertion is gone. Most likely some kernel upgrade fixed it.

Note You need to log in before you can comment on or make changes to this bug.