Bug 506985 - when DVD-ROM drive is ejected it sometimes immediately closes again
when DVD-ROM drive is ejected it sometimes immediately closes again
Status: CLOSED DUPLICATE of bug 453095
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 12:47 EDT by Aram Agajanian
Modified: 2009-06-29 04:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 04:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2009-06-19 12:47:06 EDT
Description of problem:

I have two DVD drives in my computer.  The first drive is a DVD-ROM drive and the second drive is a DVD+RW drive:

ata3.00: ATAPI: TSSTcorpDVD-ROM TS-H353B, D200, max UDMA/33
scsi 2:0:0:0: CD-ROM            TSSTcorp DVD-ROM TS-H353B D200 PQ: 0 ANSI: 5
ata4.00: ATAPI: PBDS DVD+/-RW DH-16W1S, 2D14, max UDMA/100
scsi 3:0:0:0: CD-ROM            PBDS     DVD+-RW DH-16W1S 2D14 PQ: 0 ANSI: 5

The PBDS DVD+/-RW DH-16W1S drive opens and shuts without problems.

When an already-burned DVD+R is put in the DVD-ROM drive and the drive door is closed, the drive icon changes temporarily to Blank DVD-ROM Disc.  If the drive button is pressed while this icon is visible, the drive opens normally.

When an already-burned DVD+R is put in the DVD-ROM drive and the drive door is closed, after the drive icon changes to Blank DVD-ROM Disc it then changes to TSSTcorpDVD-ROM TS-H353B: followed by the application_id of the DVD.  When the drive button is pressed after the second icon change, the drive door opens but then shuts immediately.

Selecting the Eject option in the context menu for the DVD-ROM drive object seems equivalent to pressing the drive button.

When a non-blank CD is put in the DVD-ROM drive, the door seems to open and shut without problems.  However, when the drive door is opened, the icon changes to Blank CD-ROM, which is incorrect.

Using the eject command on this drive seems to always cause the DVD-ROM drive to open and then close.  Furthermore, after using the eject command, sometimes the drive button will not work properly until it is pressed a few times.

If a blank DVD+RW is inserted into the DVD-ROM drive, it doesn't seem to recognize it.  The drive light stays on for a long time.

Version-Release number of selected component (if applicable):
eject-2.1.5-14.fc11.x86_64

How reproducible:
I think that this behavior is consistent.

Steps to Reproduce:
1. Insert non-blank DVD+R disk in SSTcorpDVD-ROM TS-H353B drive.
2. Wait for the drive icon to change to TSSTcorpDVD-ROM TS-H353B: followed by the application_id of the DVD.
3. Press the drive button.
  
Actual results:
The drive door opens and then shuts immediately.

Expected results:
The drive door should open and stay open.


Additional info:
I don't know if this problem is really due to defects in eject or in another component (perhaps part of GNOME).
Comment 1 Zdenek Prikryl 2009-06-29 04:44:50 EDT
The bug isn't in eject. It seems that this is a duplicate of the bug 453095.

*** This bug has been marked as a duplicate of bug 453095 ***

Note You need to log in before you can comment on or make changes to this bug.