Bug 506989 - poppler-ObjStream.patch inducing memory corruption
poppler-ObjStream.patch inducing memory corruption
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 13:01 EDT by Rex Dieter
Modified: 2010-02-02 09:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 15:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-06-19 13:01:50 EDT
While investigating a plethora of upstream kde/okular crash reports, lately, I came upon the fact that poppler built with  poppler-ObjStream.patch, when used with evn var
MALLOC_CHECK_=2
(or equivalent, which happens to be enabled by default during kde beta phases), poppler-based pdf viewers will segfault quite easily (usually scrolling).  I tested with both okular and evince, same badness going on.

This patch seems to go back quite a ways, but I can't determine really why we're still carrying it.  (and why not upstreamed?)

Based on the answer(s) to that, we can find ways to remove or fix/upstream this.
Comment 1 Rex Dieter 2009-06-22 15:49:41 EDT
Looks like it is indeed needed for texlive/pdftex, now documenting as such in the .spec.

I seem to be able to get crashers now using MALLOC_CHECK!=0, with or without the patch, so blame is likely elsewhere.
Comment 2 Daniel Walsh 2010-02-02 09:14:04 EST
*** Bug 560991 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.