Bug 50702 - fails : cannot determine root/boot partition
Summary: fails : cannot determine root/boot partition
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 13:29 UTC by Prabir Mitra
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 18:52:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Prabir Mitra 2001-08-02 13:29:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When I try to run mkbootdisk, it says that root partition cannot be
bound. And then exits. I have a fresh install of RedHat 7.1. My
/etc/fstab looks like:

LABEL=/                   /                   ....
LABEL=/boot               /boot               ...
/dev/hda1                 /mnt/windows98      ...
etc.

In my /etc/fstab I don't see any mount point for / and /boot. I
believe that's the source of problem. However, everything else
works fine. 

How reproducible:
Always

Steps to Reproduce:
1. run mkbootdisk
	

Actual Results:  reports error: cannot determine root partition

Expected Results:  should create a DOS boot disk

Additional info:

"df" command works fine. It reports actual mount point for 
/boot and /

Comment 1 Erik Troan 2002-06-03 18:52:49 UTC
for some reason mkbootdisk couldn't resolve your root partition from the label

this should work, and is supported. as this was against red hat 7.1, I've closed
the bug (assuming it's fixed in new releases).

if it is not fixed in 7.2, or if you need it to work for 7.1 and it doesn't,
please reopen the bug and it will get prompt attention.

sorry for the long period with no response.


Note You need to log in before you can comment on or make changes to this bug.