Bug 507022 - kernel gives "BUG: MAX_STACK_TRACE_ENTRIES too low!"
kernel gives "BUG: MAX_STACK_TRACE_ENTRIES too low!"
Status: CLOSED DUPLICATE of bug 507066
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 17:12 EDT by Richard W.M. Jones
Modified: 2009-06-20 09:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-20 09:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-06-19 17:12:05 EDT
Description of problem:

At some point my program gives the error below
when mkdir(2) is called (probably not the first time
that mkdir is called, so that may just be a coincidence).

BUG: MAX_STACK_TRACE_ENTRIES too low!
turning off the locking correctness validator.
Pid: 1, comm: guestfsd Tainted: G        W  2.6.31-0.11.rc0.git13.fc12.x86_64 #1
Call Trace:
 [<ffffffff81092a14>] save_trace+0x9d/0xba
 [<ffffffff81092abb>] add_lock_to_list+0x8a/0xe5
 [<ffffffff810952ac>] __lock_acquire+0xad2/0xc17
 [<ffffffff814dd3a5>] ? schedule+0x147/0x83b
 [<ffffffff810954df>] lock_acquire+0xee/0x12e
 [<ffffffff814dd3a5>] ? schedule+0x147/0x83b
 [<ffffffff814dd3a5>] ? schedule+0x147/0x83b
 [<ffffffff814e06a4>] _spin_lock_irq+0x51/0x9a
 [<ffffffff814dd3a5>] ? schedule+0x147/0x83b
 [<ffffffff814dd3a5>] schedule+0x147/0x83b
 [<ffffffff81089666>] ? clocksource_read+0x22/0x38
 [<ffffffff81089a76>] ? getnstimeofday+0x6e/0xd8
 [<ffffffff8108383e>] ? ktime_get_ts+0x61/0x7d
 [<ffffffff81163909>] ? sync_buffer+0x0/0x6e
 [<ffffffff814ddbb0>] io_schedule+0x44/0x6b
 [<ffffffff8116395f>] sync_buffer+0x56/0x6e
 [<ffffffff81163909>] ? sync_buffer+0x0/0x6e
 [<ffffffff814de344>] __wait_on_bit+0x57/0x9e
 [<ffffffff814de408>] out_of_line_wait_on_bit+0x7d/0x9c
 [<ffffffff81163909>] ? sync_buffer+0x0/0x6e
 [<ffffffff8107f502>] ? wake_bit_function+0x0/0x5a
 [<ffffffff8116380c>] __wait_on_buffer+0x37/0x4d
 [<ffffffff8116386c>] wait_on_buffer+0x4a/0x65
 [<ffffffff811655c1>] __bread+0x64/0x91
 [<ffffffffa001ceb3>] read_inode_bitmap+0x4e/0x97 [ext2]
 [<ffffffffa001d476>] ext2_new_inode+0x53e/0xacb [ext2]
 [<ffffffffa00207a4>] ext2_mkdir+0x5b/0x146 [ext2]
 [<ffffffff81147472>] vfs_mkdir+0x82/0xf0
 [<ffffffff811496b0>] sys_mkdirat+0xab/0x116
 [<ffffffff81012f7a>] ? sysret_check+0x2e/0x69
 [<ffffffff81093bb9>] ? trace_hardirqs_on_caller+0x139/0x175
 [<ffffffff81149746>] sys_mkdir+0x2b/0x41
 [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b

There are complete logs from two failed builds here:
http://koji.fedoraproject.org/koji/getfile?taskID=1425449&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=1425486&name=build.log
Search for "BUG".

I'm not sure if it's relevant, but I observed the problem
when running under qemu-kvm.

Version-Release number of selected component (if applicable):

kernel-2.6.31-0.11.rc0.git13.fc12.x86_64.rpm
qemu-kvm-0.10.50-6.kvm86.fc12.x86_64.rpm

How reproducible:

Observed in 2/2 builds.

Steps to Reproduce:
1. Build libguestfs 1.0.49 package in Rawhide.
2. Do 'make check'
3.
  
Actual results:

"BUG" line above causes guestfsd daemon to fail.

Expected results:

Shouldn't fail.

Additional info:

Builds that failed:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1425445
http://koji.fedoraproject.org/koji/taskinfo?taskID=1425478
Comment 1 Richard W.M. Jones 2009-06-20 09:23:45 EDT
I think I'm looking at the wrong thing in the build
log.  Marking as a duplicate (possibly) of bug 507066.

*** This bug has been marked as a duplicate of bug 507066 ***

Note You need to log in before you can comment on or make changes to this bug.