Bug 507024 - When shutting down Windows XP qemu-kvm hangs waiting on a futex
When shutting down Windows XP qemu-kvm hangs waiting on a futex
Status: CLOSED DUPLICATE of bug 495964
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 17:18 EDT by Bryan Christ
Modified: 2009-06-22 07:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 07:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2009-06-19 17:18:03 EDT
Description of problem:

When shutting down Windows XP qemu-kvm hangs waiting on a futex which never gets released.  Since Qemu will not release the mouse, the process must be killed via the console to get the mouse back.  On reboot, Windows XP is not happy about the dirty shutdown.

Version-Release number of selected component (if applicable):


How reproducible:  100%


Steps to Reproduce:
1.  Launch a Windows XP session with qemu-kvm
2.  On Windows choose Start -> Shutdown
3.  Wait
  
Actual results:

Gnome system monitor indicates that qemu-kvm is waiting for a futex that never gets unlocked.

Additional Info:

qemu-0.10.5-3.fc11.x86_64
qemu-kvm-0.10.5-3.fc11.x86_64

Launching with:

qemu-kvm -monitor stdio -boot c -m 384 -hda /home/bchrist/work/virt/winxp.img -net nic,vlan=0 -net user,vlan=0 -localtime -soundhw es1370 -sdl
Comment 1 Mark McLoughlin 2009-06-22 07:24:44 EDT
Thanks Bryan, it's a known problem - one workaround is to use "QEMU_AUDIO_DRV=pa, the other is just to remove the -soundhw argument

*** This bug has been marked as a duplicate of bug 495964 ***

Note You need to log in before you can comment on or make changes to this bug.