Bug 50703 - RH7.2 installer hangs when loading qla2x00 module
Summary: RH7.2 installer hangs when loading qla2x00 module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 13:35 UTC by Wendy Hung
Modified: 2007-04-18 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 13:21:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wendy Hung 2001-08-02 13:35:16 UTC
Description of Problem:
A Qlogic 2xxx series card, in this case a qlogic 2100 or 2200, will install
perfectly when placed in the 64-bit slot but will fail when the card is
placed in the 32-bit slot. It will lock up at loading qla2x00 module. 
Installations using "expert noprobe" and "options=verbose" have been 
attempted. Both times the install locked up when loading the module and  
was not able to switch to any of the other virtual consoles. 

How reproducible:
Always

Steps to Reproduce:
1.place card in 32bit slot. 
2.start standard install
	
Additional information:
Also seen in Red Hat 7.1.  Bugzilla #48935.

Comment 1 Glen Foster 2001-08-02 21:42:41 UTC
This defect is considered MUST-FIX for Fairfax

Comment 2 Arjan van de Ven 2001-08-02 21:57:41 UTC
Intel firmware issue

Comment 3 Michael K. Johnson 2001-08-14 19:56:07 UTC
Is this really i386 arch, or is it ia64?  (I know, dumb question, but...)

Comment 4 Yil-Kyu Kang 2001-08-14 20:07:13 UTC
i386 arch. I have not tested using IA-64.

Comment 5 Bill Nottingham 2001-08-24 18:19:15 UTC
Arjan: was your comment about intel firmware assuming ia64, or is that something
else?

Comment 6 Michael K. Johnson 2001-08-25 12:37:27 UTC
We tested this in our lab and could not reproduce it.  We put a
2200 card in a 32-bit slot and the problem did not occur for us.
Sounds like it might be related to firmware on the particular
machine in question.  What machine it is?

Comment 7 Arjan van de Ven 2001-08-26 13:08:31 UTC
cardfirmware; it appears that some versions of the firmware think they are in a
64 bit pci slot even if they aren't, and as a result half the data it sends gets
lost ;)

Comment 8 Michael K. Johnson 2001-08-26 15:03:13 UTC
Ah, so qlogic firmware rather than intel firmware.

Still, it would be interesting to know what machine this was
reproduced in at IBM so that we can see whether we have it here
and try to reproduce it with the 2200 card we tested.

Comment 9 Yil-Kyu Kang 2001-08-27 13:12:47 UTC
I used an xSeries 230 with a QLogic 2100 to reproduce the bug.

Comment 10 Wendy Hung 2001-08-28 13:20:55 UTC
IBM has reproduced this bug on an xSeries 230 and an xSeries 340.

Comment 11 Wendy Hung 2002-03-06 21:24:38 UTC
qLogic updated in Red Hat 7.2.  Works on IBM xSeries 232, but not on older 
xSeries 230 and 340.  IBM has documented the limitation for these particular 
machines.


Note You need to log in before you can comment on or make changes to this bug.