Bug 507040 - Yum Fails to execute in Fedora 11
Yum Fails to execute in Fedora 11
Status: CLOSED DUPLICATE of bug 506685
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 18:55 EDT by jcc
Modified: 2014-01-21 18:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 02:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcc 2009-06-19 18:55:07 EDT
Just updated from Fedora 10 to 11.  Yum worked in Fedora 10.  Now yum does not load.  Here's the steps taken, any hints greatly appreciated.

John Clements
jclements@grandecom.net

Typed yum as root, following appeared

"There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named yum

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6 (r26:66714, Mar 17 2009, 11:44:21)
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq "

YumFaq at question 7 states:

"If you are getting a message that yum itself is the missing module then you probably installed it incorreclty (or installed the source rpm using make/make install). If possible, find a prebuilt rpm that will work for your system like one from Fedora or CentOS. Or, you can download the srpm and do a

rpmbuild --rebuild yum*.src.rpm"

found yum-3.2.23-0.src.rpm via google and downloaded, then
typed as root rpmbuild --rebuild yum*.src.rpm per instructions above,  same result, get same error message.

Any hints?  really need yum for updates.

JCC
Comment 1 James Antill 2009-06-21 02:03:30 EDT

*** This bug has been marked as a duplicate of bug 506685 ***

Note You need to log in before you can comment on or make changes to this bug.