Bug 507046 - Cobbler virt mem settings don;t match Satellite
Cobbler virt mem settings don;t match Satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Partha Aji
Milan Zazrivec
https://<URL>/rhn/kickstart/Kickstart...
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-06-19 22:17 EDT by Partha Aji
Modified: 2009-09-10 15:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Partha Aji 2009-06-19 22:17:51 EDT
Description of problem:

Cobbler's virtual memory settings are listed in MBs while satellites virtual memory settings are listed in KBs. But satellite does not translate KB to MB while setting in cobbler.
Interestingly while provisioning virt guests in the advanced screen  we have the Memory values listed in MB...
We must either have satellite profiles use Virt Memory specified in MB (which may break upgrades...) or use KB every where and normalize it to cobbler..

Version-Release number of selected component (if applicable): Sat 530 jun 19 09 build


How reproducible: always


Steps to Reproduce:
1. Goto kickstart details page
2. set a value for Virtual Memory (in kilobytes) -> 256000
3. hit update
4. On the command line 
sudo cobbler profile list -> identify your profile
sudo cobbler profile report --name=<profileName>

  
Actual results:
notice virt ram is listed as the number you specified.

Expected results:
notice virt ram/1000 because virt ram is in MB in cobbler.
you can confirm this by trying
sudo cobbler profile edit --help 
and noticing
  --virt-ram=VIRT_RAM   size in MB

5) Goto system details of a system with virtualization ent
6) Goto virtualization -> provisioning
7) Give a guest name, select the profile you modified in the KS details page
8) Notice it says "256000" MB of 512 mb available in the system.. In essence our own virt provisioning page is confused if the 256000 is KB or MB



Additional info:
Comment 1 Partha Aji 2009-06-22 12:52:15 EDT
should be fixed in the next iso as of http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=f8c300f21c42b4f02260684b42a0bdcc673ed62c
Comment 2 Partha Aji 2009-06-24 11:34:13 EDT
Moving to ON_QA
Comment 3 Milan Zazrivec 2009-06-30 07:45:02 EDT
Satellite-5.3.0-RHEL5-re20090625.0 / spacewalk-java-lib-0.5.44-26

I'm confirming that the memory sizes now are consistent across
the webui & on cobbler command line (all shown in MB).
Comment 4 Steve Salevan 2009-07-30 09:41:13 EDT
RELEASE_PENDING from 7/24 ISO.
Comment 5 Brandon Perkins 2009-09-10 15:26:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.