Bug 507047 - lirc_i2c no longer functional
lirc_i2c no longer functional
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 23:08 EDT by David Smith
Modified: 2009-07-22 17:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6.29.6-213.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Smith 2009-06-19 23:08:43 EDT
Description of problem:

Upgraded system from f9 to f11.  Now lirc no longer works (on my Hauppauge PVR-350).

Version-Release number of selected component (if applicable):

kernel: 2.6.29.4-167.fc11.x86_64
lirc-0.8.5-2.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:

Under f9, the following additions to /etc/modprobe.d/local.conf worked correctly:

# ivtv/lirc modules setup
alias char-major-61 lirc_i2c
alias char-major-81 videodev
alias char-major-81-0 ivtv
install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install lirc_i2c

This produced a /dev/lirc that worked correctly.  Both mode2 and irw displayed correct output.

After upgrading to f11, lirc no longer works.  

Upon boot, the following message appear in /var/log/messages:

un 19 22:02:06 localhost kernel: lirc_dev: IR Remote Control driver registered, major 242 
Jun 19 22:02:06 localhost kernel: lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge IR)
Jun 19 22:02:06 localhost kernel: lirc_dev: lirc_register_driver: sample_rate: 10
Jun 19 22:02:06 localhost lircd-0.8.5[3250]: lircd(default) ready

One problem there might be that the device major number is 242, not 61.

crw-rw---- 1 root root 242, 0 2009-06-19 22:02 /dev/lirc0

Here's what mode2 reports:

# mode2 --raw
read() failed

When irw is run, it reports nothing, but in /var/log/message I get the following error for every button press on the remote:

Jun 19 22:05:32 localhost lircd-0.8.5[3250]: reading in mode LIRC_MODE_LIRCCODE failed


Additional info:

When gnome-lirc-properties is run, everything is grayed out.
Comment 1 Darwin Slattery 2009-06-20 12:05:46 EDT
Just adding that I also have experienced this problem since I upgraded to fedora 11 from fedora 10.

System information:
 kernel-2.6.29.4-167.fc11.i586
 lirc-0.8.5-2.fc11.i586
 SELinux: permissive
 Hauppauge PVR-350 capture card

/var/log/messages:
Jun 20 15:46:42 localhost kernel: lirc_dev: IR Remote Control driver registered, major 248
Jun 20 15:46:42 localhost kernel: lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge IR)
Jun 20 15:46:42 localhost kernel: lirc_dev: lirc_register_driver: sample_rate: 10
Jun 20 15:46:42 localhost kernel: lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge IR)
Jun 20 15:46:42 localhost kernel: lirc_dev: lirc_register_driver: sample_rate: 10
Jun 20 15:46:43 localhost lircd-0.8.5[2023]: lircd(default) ready
Jun 20 15:47:09 localhost lircd-0.8.5[2023]: accepted new client on /dev/lircd
Jun 20 15:47:18 localhost lircd-0.8.5[2023]: accepted new client on /dev/lircd
Jun 20 16:45:33 localhost lircd-0.8.5[2023]: accepted new client on /dev/lircd
Jun 20 16:45:41 localhost lircd-0.8.5[2023]: reading in mode LIRC_MODE_LIRCCODE failed
Jun 20 16:45:45 localhost lircd-0.8.5[2023]: removed client
Comment 2 Keith Bare 2009-06-21 09:29:46 EDT
I'm having a similar problem with f10. After unsuccessfully trying to install f11 due to problems with anaconda and raid, I did a fresh install of f10. After updating everything, I eventually installed the lirc packages.  When trying to configure lirc, I couldn't get any output from irw.  After trying for a couple hours, I just reinstalled f10 figuring I had done something incorrectly.  The first thing I did on the new install was try out lirc.  It still didn't work.  I proceeded to remove the most recent version 8.5-2. and downgrade to the packages that shipped with f10 8.4a-1 and worked in the past.  This proved successful as everything now works as it should.

System information:
kernel-2.6.27.24-170.2.68.fc10.x86_64
lirc-0.8.5-2.fc10.x86_64
SELinux: permissive
Hauppauge PVR-350 capture card

Here is the relevant output from /var/log/messages:

Jun 20 23:14:35 localhost kernel: lirc_dev: IR Remote Control driver registered, major 61 
Jun 20 23:14:35 localhost kernel: bttv: driver version 0.9.17 loaded
Jun 20 23:14:35 localhost kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Jun 20 23:14:35 localhost kernel: cx88/0: cx2388x v4l2 driver version 0.0.6 loaded
Jun 20 23:14:35 localhost kernel: lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge IR)
Jun 20 23:14:35 localhost kernel: lirc_dev: lirc_register_plugin: sample_rate: 10
Jun 20 23:14:57 localhost lircd-0.8.5[3946]: lircd(default) ready
Jun 20 23:15:03 localhost lircd-0.8.5[3946]: accepted new client on /dev/lircd
Jun 20 23:15:03 localhost lircd-0.8.5[3946]: could not get hardware features
Jun 20 23:15:03 localhost lircd-0.8.5[3946]: this device driver does not support the LIRC ioctl interface
Jun 20 23:15:03 localhost lircd-0.8.5[3946]: make sure you use a current version of the driver
Jun 20 23:15:03 localhost lircd-0.8.5[3946]: Failed to initialize hardware
Jun 20 23:15:34 localhost lircd-0.8.5[3946]: removed client
Jun 20 23:15:48 localhost ntpd[2909]: synchronized to 129.174.93.11, stratum 3
Jun 20 23:15:48 localhost ntpd[2909]: kernel time sync status change 0001
Jun 20 23:17:26 localhost lircd-0.8.5[3946]: caught signal
Jun 20 23:17:26 localhost yum(yumex): Erased: lirc
Jun 20 23:17:28 localhost yum(yumex): Erased: lirc-doc
Jun 20 23:17:28 localhost yum(yumex): Erased: lirc-libs
Jun 20 23:20:07 localhost ntpd[2909]: synchronized to 75.144.70.35, stratum 2
Jun 20 23:23:46 localhost yum: Installed: lirc-libs-0.8.4a-1.fc10.x86_64
Jun 20 23:23:47 localhost yum: Installed: lirc-0.8.4a-1.fc10.x86_64
Jun 20 23:23:47 localhost yum: Installed: lirc-doc-0.8.4a-1.fc10.x86_64
Jun 20 23:24:11 localhost lircd-0.8.4a[4169]: lircd(default) ready
Jun 20 23:24:19 localhost lircd-0.8.4a[4169]: accepted new client on /dev/lircd
Jun 20 23:32:24 localhost lircd-0.8.4a[4169]: removed client
Comment 3 Jarod Wilson 2009-06-24 16:38:19 EDT
So there are two different issues...

One, the 2.6.27.x kernels in F10 aren't compatible with lirc 0.8.5, but work with 0.8.4a, as Keith discovered in comment #2. That'll be remedied once F10 bumps to a 2.6.29 kernel soon here...

Second, and the more troubling one, is apparently lirc_i2c no longer works... Which is presently rather baffling, as that code hasn't changed much at all any time recently that I can remember... Fortunately, I do have a fodder box with a PVR-250 in it, which has an onboard lirc_i2c-driven IR receiver, so I'll see what I can figure out...
Comment 4 Jarod Wilson 2009-06-24 21:13:43 EDT
Okay, I reproduced the problem with my PVR-250. Current lirc cvs works, but lirc_i2c itself has no significant difference. Tracked it down to a minor difference in buffer length calculation in lirc_dev.c though, and now I've got it working again w/the in-kernel lirc. Will get the Fedora 2.6.29.x and up kernel patches updated shortly.
Comment 5 Jarod Wilson 2009-06-24 22:47:17 EDT
Fixed up kernel building now, please give it a test run when its done building:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1434633
Comment 6 Darwin Slattery 2009-06-25 15:31:36 EDT
Many thanks Jarod - lirc works again on F11 after installing that kernel update.

Thanks also for your invaluable 'Fedora Myth(tv)ology' site. I used it a few years ago to get MythTV up and running and found it very useful.

Thanks again,
Darwin
Comment 7 Fedora Update System 2009-07-08 08:14:18 EDT
kernel-2.6.29.6-213.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.29.6-213.fc11
Comment 8 Fedora Update System 2009-07-16 03:13:14 EDT
kernel-2.6.29.6-213.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7617
Comment 9 David Smith 2009-07-17 10:48:06 EDT
I've tested 2.6.29.6-213.fc11 and it seems to work fine for me.
Comment 10 Fedora Update System 2009-07-22 17:57:55 EDT
kernel-2.6.29.6-213.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.