Bug 507056 - transmission-1.71-1.fc11 doesn't allow incoming connections
transmission-1.71-1.fc11 doesn't allow incoming connections
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 06:52 EDT by Andre Robatino
Modified: 2013-03-13 01:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 00:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2009-06-20 06:52:00 EDT
Description of problem:
After applying all updates including transmission 1.71-1, I suddenly couldn't get any incoming connections through my chosen port, even though transmission itself said that port was open.  After downgrading just transmission to the original 1.53-1, incoming connections were back.

Version-Release number of selected component (if applicable):
transmission-1.71-1.fc11

How reproducible:
always

Steps to Reproduce:
1. Join a torrent with lots of peers.
  
Actual results:
No incoming connections.

Expected results:
Some incoming connections.
Comment 1 Rahul Sundaram 2009-06-20 14:58:25 EDT
I downloaded Fedora Edu Spin via torrent with this version and didn't have this problem. Can't reproduce this. Can you point me to the specific torrent you had a problem with? Can you try with other torrent files. 

Example:

http://torrent.fedoraproject.org/torrents//Fedora-11-i686-Live.torrent
Comment 2 Rahul Sundaram 2009-06-20 20:06:11 EDT
While the reported bug isn't reproducible by me, I just wanted to note that a new upstream release 1.72 has been built for Fedora 11 and pushed to updates-testing repo

https://admin.fedoraproject.org/updates/transmission-1.72-1.fc11

It is waiting on rel-eng to sign it but you would be able to pull it from koji. Appreciate your testing since it might fix the problem for you
Comment 3 Andre Robatino 2009-06-20 22:42:58 EDT
The torrent in Comment #1 was the exact one I tested.  In any case, the problem disappears with 1.72-1, comes back when downgrading to 1.71-1, without any other configuration changes.  Left feedback for 1.72-1.
Comment 4 Rahul Sundaram 2009-06-21 04:14:19 EDT
Thanks for confirming. I am pushing this update directly to stable.
Comment 5 Charles Kerr 2009-06-21 05:46:07 EDT
Andre: I think you're right about this.  It was a copy-paste error introduced
in 1.71 by <http://trac.transmissionbt.com/changeset/8636/trunk/libtransmission/fdlimit.c>, and fixed in 1.72 by <http://trac.transmissionbt.com/changeset/8654/trunk/libtransmission/fdlimit.c>.
Comment 6 Andre Robatino 2009-06-25 00:42:49 EDT
The version transmission-1.72-1 from updates-released also works, closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.