Bug 507094 - Anaconda crash after package selection
Anaconda crash after package selection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
anaconda_trace_hash:a7863726be341c90b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 16:05 EDT by Andrew McNabb
Modified: 2014-01-21 18:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 17:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (374.68 KB, text/plain)
2009-06-20 16:05 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2009-06-20 16:05:43 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 434, in getOldProvides
    for pkg, hits in self.rpmdb.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 441, in getProvides
    result = self.getOldProvides(name, flag, version)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 856, in _checkInstall
    provs = self.tsInfo.getProvides(*req)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 784, in _resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 699, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 717, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1311, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 279, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'getProvides'
Comment 1 Andrew McNabb 2009-06-20 16:05:48 EDT
Created attachment 348758 [details]
Attached traceback automatically from anaconda.
Comment 2 seth vidal 2009-06-29 16:15:37 EDT
the rpmdb was never opened here. Does this happen every time for you?
Comment 3 Andrew McNabb 2009-06-29 16:30:14 EDT
This happened along with bug 507093, which might be the primary cause of the problem.  It's hard to say whether it happens every time because it takes several steps to reproduce the problem.  If 507093 is the main cause, maybe there just needs to be a message for this error.
Comment 4 seth vidal 2009-10-12 17:36:34 EDT
I suspect it is directly related.
I'm just going to close this rather than dupe'ing it to that one.

essentially close 507093 and I think this one just vanishes.

Note You need to log in before you can comment on or make changes to this bug.