Bug 507120 - messed up gnome-volume-control-applet icon
messed up gnome-volume-control-applet icon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 22:49 EDT by Jonathan Kamens
Modified: 2009-07-28 22:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 22:17:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot fragment (6.86 KB, image/gif)
2009-06-20 22:49 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2009-06-20 22:49:38 EDT
Created attachment 348775 [details]
screen shot fragment

I've just updated from rawhide.

The attached screen shot fragment shows the applet icon area of my GNOME panel.  There are two messed up applet icons in it.  The one on the right, with the mostly white flecks on the grey background, is the icon being displayed by gnome-volume-control-applet.
Comment 1 Bastien Nocera 2009-06-24 09:42:53 EDT
That looks like corruption in the icon theme cache.

Run something like:
gtk-update-icon-cache -f /usr/share/icons/<theme name>/
to get the icon cache updated.
Comment 2 Jonathan Kamens 2009-06-24 09:49:53 EDT
1. If you're right, then how did the cache get corrupted?  That would be a bug, no?
2. I have no idea how to figure out which theme's icon cache to update.  Can you give me a hint?
Comment 3 Bastien Nocera 2009-06-24 10:06:40 EDT
(In reply to comment #2)
> 1. If you're right, then how did the cache get corrupted?  That would be a bug,
> no?

I don't know, your hard drive is dying, cosmic rays, crash during an update...

> 2. I have no idea how to figure out which theme's icon cache to update.  Can
> you give me a hint?  

Update them all...
Comment 4 Jonathan Kamens 2009-06-25 06:59:05 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > 1. If you're right, then how did the cache get corrupted?  That would be a bug,
> > no?
> 
> I don't know, your hard drive is dying, cosmic rays, crash during an update...

Assuming user error when the user is clueless might be appropriate.  It is not, however, appropriate for someone who has been using Linux since Slackware 1.0 and various UNIXes for years before that, builds kickstart files in his sleep, has been a Red Hat beta tester and/or Fedora tester for years, and is one of the top bug reporters of all time in Red Hat bugzilla, with many of his bug reports including patches.  Please remember my name, and the next time you triage a bug that I submit, please give me the courtesy of not treating me like an idiot.  Thanks.

> > 2. I have no idea how to figure out which theme's icon cache to update.  Can
> > you give me a hint?  
> 
> Update them all...  

Done.  Then logged out and logged back in.  Didn't help, nor did I think it would.  Gcc bug 506952 is a more likely explanation for what the problem is here.
Comment 5 Yanko Kaneti 2009-06-25 11:05:49 EDT
I am seeing a similar thing here and it seems to be related to the kernel.
Fine with 2.6.29.5-198.fc11.x86_64 , corrupt volume (and others in the notification area) icon with kernel-2.6.31 rc0 and rc1 rawhide kernels.
Same latest rawhide userspace   on radeon RS7800 (HD3200/R600, no kms).

Anything similar on your end ?
Comment 6 Matthias Clasen 2009-06-27 17:13:45 EDT
> Assuming user error when the user is clueless might be appropriate.  It is not,
> however, appropriate for someone who has been using Linux since Slackware 1.0
> and various UNIXes for years before that, builds kickstart files in his sleep,
> has been a Red Hat beta tester and/or Fedora tester for years, and is one of
> the top bug reporters of all time in Red Hat bugzilla, with many of his bug
> reports including patches.  Please remember my name, and the next time you
> triage a bug that I submit, please give me the courtesy of not treating me like
> an idiot.  Thanks.

Jonathan, your biography is a) not known to us (and assuming  that it should is a bit presumptuous of you) and b) doesn't entitle you to special treatment here. 

Bastien was asking you for a simple bit of additional information. That is a far cry from teating you like an idiot. Your reaction on the other hand...
Comment 7 Jonathan Kamens 2009-06-27 21:25:37 EDT
(In reply to comment #6)
> Jonathan, your biography is a) not known to us (and assuming  that it should is
> a bit presumptuous of you) and b) doesn't entitle you to special treatment
> here. 

You're right, I'm not entitled to special treatment.  What I am entitled to is the respectful treatment that Bastien, and all of the other triagers, should be giving to ALL bug submitters, whether it's the first bug they've submitted or the thousandth.

And that means assuming that the submitter knows what he's talking about and that he's reporting a real bug, rather than assuming that a more likely explanation is "your hard drive is dying, cosmic rays, crash during an update..."

I have noticed a marked deterioration in the last year or two in how bug submitters are treated here.  Quite frankly, a lot of the people triaging bugs nowadays seem to have a chip on their shoulders and operate from the assumption that the people submitting bugs are idiots.  Yes, I snapped at Bastien in particular, but I assure you that he isn't the first triager who has made it clear to me that he thinks he's smarter than the people submitting bugs.  This is not a productive attitude.

If you assume somebody knows what he's talking about and you turn out to be wrong, you've lost nothing.  If you assume that someone is an idiot and it turns out that they're not, you've lost their goodwill, and it's awfully hard to get that back.

Just something to think about.

Note You need to log in before you can comment on or make changes to this bug.