Bug 507128 - Excessively slow for all but trivial designs
Excessively slow for all but trivial designs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pcb (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 03:25 EDT by John Bass
Modified: 2009-09-28 15:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 15:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple test case (797.35 KB, text/plain)
2009-06-21 04:02 EDT, John Bass
no flags Details

  None (edit)
Description John Bass 2009-06-21 03:25:13 EDT
Description of problem:

Since pcb-20050315 pcb has been excessively slow, to the point of completely broken, for all but simple student designs.

This issue has been repeatedly raised with Harry, DJ, and Peter. Design fragments have been provided to all developers to demonstrate the problem.

There are some serious, fatal memory leaks.


Version-Release number of selected component (if applicable):


How reproducible:

Always, up to pcb-20050315 large complex boards are snappy in the UI. Since the GTK conversion, it's been completely unusable.


Steps to Reproduce:
1. load attached design fragment "pcb testing.pcb"
2. Close log and library windows.
3. Select file->Save connection data of->unused pins
   Note: click on "file" ONCE and leave mouse alone ... will take a few minutes for drop down box to appear, same with secondary box selection.
4. change file save dialog name to testing.nc
   Note: this is also a bug ... dialog box should NEVER present original design file name for a report output.
  
Actual results:

Under pcb-20050315, all operations on this design fragment will complete in a second to a few seconds or so.

Under the current release, all operations on this design may run for a few minutes to a few days, and some like unused pins are not likely to complete

Expected results:

File to load to command state in a few seconds.
list of unconnected pins in a minute or so.

Additional info:
Comment 1 John Bass 2009-06-21 04:02:10 EDT
Created attachment 348776 [details]
simple test case

plain text PCB design file
Comment 2 Chitlesh GOORAH 2009-09-13 07:09:38 EDT
On behalf of Maciej Pijanka:

Can you verify if switching to thin draw of poly help in any way with time-of-reaction of menu etc ?

Note You need to log in before you can comment on or make changes to this bug.