Bug 507132 - Please update font links and deps
Please update font links and deps
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: php-ZendFramework (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-06-21 03:43 EDT by Nicolas Mailhot
Modified: 2010-08-20 01:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 01:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-06-21 03:43:37 EDT
Description of problem:

php-ZendFramework-tests  links to Bitstream Vera

It is a good idea to make the symlinks point to the corresponding DejaVu (full) packages. DejaVu (full) is the most complete fork of Bitstream Vera. It should include all the material present in Vera and its other derivatives, plus multiple fixes. Since we install the DejaVu (full) packages by default, dependencies on them will usually not pull in new packages on user systems.

Version-Release number of selected component (if applicable):

0:1.7.7-2.fc11
Comment 1 Alexander Kahl 2009-06-29 04:38:09 EDT
Sounds reasonable, will handle this together with the next ZF update.
Comment 2 Alexander Kahl 2009-07-17 07:35:11 EDT
I've looked into this: The Zend Framework tests MUST link to bitstream-vera, else they don't work. Finally it's just unit testing and "fixing" this doesn't improve user experience in any way.

Please share your thoughts on this; if no arguments remain, I'll close "WONTFIX" or "NOTABUG".
Comment 3 Nicolas Mailhot 2009-07-20 08:33:53 EDT
(In reply to comment #2)
> I've looked into this: The Zend Framework tests MUST link to bitstream-vera,
> else they don't work.   

Ok, that's a pity, but I guess when we'll have weeded out the other remaining users of Vera you'll be best placed to take over the maintenance of this package :p
Comment 4 Alexander Kahl 2009-07-20 08:49:40 EDT
Frankly: In my opinion the new font packaging guidelines shouldn't apply here at all anyway since they just form static *test data* to showcase the framework is working at all and they are not even used, visible or whatever during regular usage of the package. 

rpmlint also yields a plethora of other errors for the -tests subpackage that must be ignored since broken, misplaced and empty files are *desired* here to test correct error handling.

But who to ask?
Comment 5 Bug Zapper 2010-03-15 08:40:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Felix Kaechele 2010-08-20 01:56:21 EDT
Test package was removed some time ago.

Note You need to log in before you can comment on or make changes to this bug.