Bug 507135 - A dependency error crashes yum with a ValueError: incomplete format
A dependency error crashes yum with a ValueError: incomplete format
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 04:07 EDT by Aurelien Bompard
Modified: 2014-01-21 18:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 16:33:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aurelien Bompard 2009-06-21 04:07:42 EDT
Description of problem:
When there is a dependency error, Yum crashes with a ValueError. This is probably due to the french translation. Here's the output:

# yum --changelog --skip-broken update
[...]
Est-ce correct [o/N] : o                                                                               
Lancement de rpm_check_debug
ERREUR de résolution de dépendance par rpm_check_debug :
python(abi) is needed by (installed) pywbxml-0.1-3.fc9.i386
python(abi) is needed by (installed) plucker-1.8-1.fc10.i386
python(abi) is needed by (installed) pykaraoke-0.6-1.fc10.i386
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)            
  File "/usr/share/yum-cli/yummain.py", line 261, in main
    return_code = base.doTransaction()        
  File "/usr/share/yum-cli/cli.py", line 426, in doTransaction
    return 1, [_('Please report this error in %s') % self.conf.bugtracker_url]
ValueError: incomplete format

Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch

How reproducible: always, if you have a dependency error to test it on...
Comment 1 seth vidal 2009-06-24 16:33:41 EDT
yep - translation replaced %s with %

fixed upstream.

thanks

Note You need to log in before you can comment on or make changes to this bug.