Bug 507139 - Digital output profile switches digital output on and off
Digital output profile switches digital output on and off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 04:30 EDT by Christian Nolte
Modified: 2009-06-25 11:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2009-06-21 04:30:56 EDT
I have a SB Audigy, with activated profile 'Output Digital Stereo (IEC958)...' via pavucontrol. If no sound is being played back, pulseaudio switches the digital out off (I can see that on my external amp, which then says 'NO AUDIO' and mutes the channels). 

If something is played back, PA switches the digital out on (external amp detects this, and unmutes; takes about one second). This leads to a situation where the first second of a song can simply not be heard.

If i stop playback, PA switches the digital out off again after a few seconds. 

This is really annoying. This profile should let the digital out signal on indefinitely (like the underlying alsa does if one enables digital out).
Comment 1 Lennart Poettering 2009-06-25 11:58:47 EDT
This is not a bug in PA. If at all in your audio equipment.

To save power we have to close the audio devices when we are idle. 

As a workaround you can comment loading of "module-suspend-on-idle" in /ect/pulse/default.pa which will make sure that the audio devices are constantly kept open. This will burn needless CPU time and power but will output a constant PCM stream on your SPDIF at all times.

Note You need to log in before you can comment on or make changes to this bug.