Bug 507142 - Partitions not found in /dev
Partitions not found in /dev
Status: CLOSED DUPLICATE of bug 504961
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 04:43 EDT by andiburget
Modified: 2009-06-26 05:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 05:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andiburget 2009-06-21 04:43:36 EDT
I don't know if this concerns HAL or udev but I had to make a choice :)

Description of problem:
After updating from F10 to F11 via Preupgrade I'm not able to mount my Data drives.
the partitions are recognized on boot up but don't show up in /dev. The partition tables are readable with fdisk and cfdisk.
here's some Info that might be useful...
fdisk -l in F11 http://fpaste.org/paste/15780
fdisk -l in F10 LiveCD http://fpaste.org/paste/15781
/dev http://fpaste.org/paste/15866
fstab http://fpaste.org/paste/15779
blkid http://fpaste.org/paste/15865
/var/log/messages output http://fpaste.org/paste/15934

Version-Release number of selected component (if applicable):


How reproducible:
Update from F10 to F11 via Preupgrade?

Steps to Reproduce:
1. 
2. 
3.
  
Actual results:
partitions don't appear in /dev and are not mountable

Expected results:
partitions mountable...

Additional info:
Comment 1 Harald Hoyer 2009-06-22 05:14:41 EDT
/dev/sdc1 * 1 30401 244196001 a5 FreeBSD
/dev/sdd2 * 14 25509 204796620 83 Linux

So you are missing sdc1 and sdd2??
Comment 2 andiburget 2009-06-22 13:19:41 EDT
yes, I'm missing sdb1 sdc1 and sdd2
they don't appear in /dev and they aren't assigned a UUID, so I don't see a way to mount them.
Comment 3 Harald Hoyer 2009-06-25 08:23:10 EDT
Please paste the output of:
# dmraid -tay -vvv
Comment 4 andiburget 2009-06-25 18:36:36 EDT
# dmraid -tay -vvv
WARN: locking /var/lock/dmraid/.lock
NOTICE: skipping removable device /dev/sde
NOTICE: /dev/sdd: asr     discovering
NOTICE: /dev/sdd: ddf1    discovering
NOTICE: /dev/sdd: hpt37x  discovering
NOTICE: /dev/sdd: hpt45x  discovering
NOTICE: /dev/sdd: isw     discovering
NOTICE: /dev/sdd: jmicron discovering
NOTICE: /dev/sdd: lsi     discovering
NOTICE: /dev/sdd: nvidia  discovering
NOTICE: /dev/sdd: pdc     discovering
NOTICE: /dev/sdd: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdd: sil metadata discovered
NOTICE: /dev/sdd: via     discovering
NOTICE: /dev/sdc: asr     discovering
NOTICE: /dev/sdc: ddf1    discovering
NOTICE: /dev/sdc: hpt37x  discovering
NOTICE: /dev/sdc: hpt45x  discovering
NOTICE: /dev/sdc: isw     discovering
NOTICE: /dev/sdc: jmicron discovering
NOTICE: /dev/sdc: lsi     discovering
NOTICE: /dev/sdc: nvidia  discovering
NOTICE: /dev/sdc: pdc     discovering
NOTICE: /dev/sdc: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdc: sil metadata discovered
NOTICE: /dev/sdc: via     discovering
NOTICE: /dev/sdb: asr     discovering
NOTICE: /dev/sdb: ddf1    discovering
NOTICE: /dev/sdb: hpt37x  discovering
NOTICE: /dev/sdb: hpt45x  discovering
NOTICE: /dev/sdb: isw     discovering
NOTICE: /dev/sdb: jmicron discovering
NOTICE: /dev/sdb: lsi     discovering
NOTICE: /dev/sdb: nvidia  discovering
NOTICE: /dev/sdb: pdc     discovering
NOTICE: /dev/sdb: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdb: sil metadata discovered
NOTICE: /dev/sdb: via     discovering
NOTICE: /dev/sda: asr     discovering
NOTICE: /dev/sda: ddf1    discovering
NOTICE: /dev/sda: hpt37x  discovering
NOTICE: /dev/sda: hpt45x  discovering
NOTICE: /dev/sda: isw     discovering
NOTICE: /dev/sda: jmicron discovering
NOTICE: /dev/sda: lsi     discovering
NOTICE: /dev/sda: nvidia  discovering
NOTICE: /dev/sda: pdc     discovering
NOTICE: /dev/sda: sil     discovering
NOTICE: /dev/sda: via     discovering
NOTICE: added /dev/sdd to RAID set "sil_afafadcfcfah"
NOTICE: added /dev/sdc to RAID set "sil_afafadcfcfah"
NOTICE: added /dev/sdb to RAID set "sil_afafadcfcfah"
sil_afafadcfcfah: 0 976791040 raid45 core 2 131072 nosync raid5_ls 1 128 3 1 /dev/sdd 0 /dev/sdb 0 /dev/sdc 0
INFO: Activating raid5_ls raid set "sil_afafadcfcfah"
WARN: unlocking /var/lock/dmraid/.lock
Comment 5 Harald Hoyer 2009-06-26 05:03:12 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=504961#c13

*** This bug has been marked as a duplicate of bug 504961 ***

Note You need to log in before you can comment on or make changes to this bug.