Bug 507155 - Messes up screen resolution on exit
Messes up screen resolution on exit
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cylindrix (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 06:30 EDT by Ian Chapman
Modified: 2010-05-13 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 12:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace on x86_64 (15.19 KB, text/plain)
2009-06-23 11:29 EDT, Ian Chapman
no flags Details

  None (edit)
Description Ian Chapman 2009-06-21 06:30:04 EDT
Description of problem:

Cylindrix aborts on exit which has the side effect of leaving the desktop in a horribly small resolution, such as 640x480. It aborts with the following error:

FIXME in main.c: not freeing pcx data in free_menu_stuff - was causing hang.
Aborted


Version-Release number of selected component (if applicable):
cylindrix-1.0-9.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Launch the game
2. Quit the game
3.
  
Actual results:

Game aborts leaving the desktop with a messed up resolution


Expected results:

Game should quit gracefully allow the desktop resolution to be restored.

Additional info:
Comment 1 Gwyn Ciesla 2009-06-22 12:38:00 EDT
I'm not seeing this, in either Windowed or Fullscreen modes.  Can you reproduce this on other hardware, specifically other video hardware?
Comment 2 Ian Chapman 2009-06-23 11:28:54 EDT
Hi,

Yes I tried on different hardware, the only other hardware I have running Fedora 11 is a PPC Mac. Unfortunately the situation was even worse there, where it crashes shortly after startup. I've raised a new bug (507639) for that as it appears to be different. The issue may also exist on the other machine but I can't get cylindrix to even run that far.

For reference, my X86_64 laptop has:

01:00.0 VGA compatible controller: nVidia Corporation GeForce 9600M GT (rev a1)

The PPC Mac laptop has:

0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]


I was running the proprietary nvidia drivers on the X86_64 laptop so I double checked using nouveau and it results in the same problem. The PPC Mac is obviously running the FOSS drivers (radeon). 

I've also attached backtrace
Comment 3 Ian Chapman 2009-06-23 11:29:20 EDT
Created attachment 349104 [details]
Backtrace on x86_64
Comment 4 Gwyn Ciesla 2009-06-23 11:52:56 EDT
Hmm.  I'll try to see if I can find a PPC box to test with.

On the PPC, what happens if you use the vesa driver?
Comment 5 Ian Chapman 2009-06-23 11:56:11 EDT
I've just tried an F11 (x86_64) virtual machine running under VirtualBox and the same problem occurs as reported for my X86_64 laptop. I'll trying with the VESA drivers on the PPC laptop.
Comment 6 Ian Chapman 2009-06-23 12:20:13 EDT
I don't appear to be able to use the VESA driver on the PPC Mac. X receives a signal 7, shortly after trying to POST the card on Int 10. I'm not sure if that's because you can't use the VESA drivers on this platform or whether it's an X bug.
Comment 7 Ian Chapman 2009-06-25 13:50:02 EDT
I'm curious, are you at least seeing

FIXME in main.c: not freeing pcx data in free_menu_stuff - was causing hang.
Aborted

when you run it from the command line?
Comment 8 Gwyn Ciesla 2009-06-29 08:34:51 EDT
I also get that error.  I may have access to test on PPC shortly.
Comment 9 Bug Zapper 2010-04-27 11:07:46 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Gwyn Ciesla 2010-05-10 12:55:46 EDT
I can't get hold of a ppc box.  Is this still occurring?
Comment 11 Ian Chapman 2010-05-13 10:43:39 EDT
I still get the same error on exit, however it seems to restore the screen resolution on exit at least now.
Comment 12 Gwyn Ciesla 2010-05-13 11:09:36 EDT
So. . .I suppose it's not a bug, as the error is basically noise.  Shall I close?
Comment 13 Ian Chapman 2010-05-13 11:44:24 EDT
Well I suppose it is technically a bug because it appears not to be exiting cleanly, however I no longer get the messed up the screen res and otherwise it seems harmless. I'm happy for it to be closed. Thanks Jon.
Comment 14 Gwyn Ciesla 2010-05-13 12:58:34 EDT
Ok, done.  Thanks.

I may investigate the message and see what I can do.

Note You need to log in before you can comment on or make changes to this bug.