This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 507193 - COPYING file broken in mc package
COPYING file broken in mc package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 11:12 EDT by Christian Krause
Modified: 2013-07-02 19:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-29 04:58:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for mc.spec to covert COPYING symlink into regular file (459 bytes, patch)
2009-06-21 11:12 EDT, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2009-06-21 11:12:19 EDT
Created attachment 348797 [details]
patch for mc.spec to covert COPYING symlink into regular file

Description of problem:

The COPYING file of the mc package is only a symlink to /usr/share/automake-1.10/COPYING. This lead to problems if e.g. the automake package is update after a mc build, since the target of the symlink will be not available anymore.
This happened e.g. just now in F10:

mc-4.6.2-8.fc10.i386
automake-1.11-2.fc10.noarch

ls -la /usr/share/doc/mc-4.6.2/COPYING 
lrwxrwxrwx 1 root root 32 2009-06-03 19:03 /usr/share/doc/mc-4.6.2/COPYING -> /usr/share/automake-1.10/COPYING

Version-Release number of selected component (if applicable):
- the problem is in all releases of mc in Fedora (F10, F11, rawhide)

Additional info:

Most likely it would be better that the package would contain a real file for the license information and not only a symbolic link. Since it looks like that it is upstream's intention to always use the most recent COPYING from the installed automake (./autogen.sh updates the COPYING symlink), I suggest that the symlink is just coverted to a regular file containing the target's content at compile time.

I've attached a patch for mc.spec.
Comment 1 Bug Zapper 2009-11-18 07:06:57 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Christian Krause 2009-11-18 11:06:00 EST
The problem is still in F12 and F11.

It's now nearly half a year after I've reported the bug. :-(

I've already attached a patch and the problem can be solved without any risk to the package itself.

It would be great if the integrity of the license file could be restored in both stable versions of Fedora, too. ;-) Thanks!
Comment 3 Jindrich Novy 2009-11-18 11:13:14 EST
Christian, it seems that upstream is going to release an official release of the new mc quite soon. The problem will be resolved once forever as soon as mc-4.7.0 is officially released. And I will be happy to release updates ASAP then :)
Comment 4 Slava Zanko 2010-01-28 20:16:53 EST
Actually, bug solved. Now file ${srcdir}/COPYING it's a symlink to ${srcdir}/doc/COPYING regular file.

Note You need to log in before you can comment on or make changes to this bug.