Bug 507217 - need an explicit load of netiucv module in ifup-iucv
need an explicit load of netiucv module in ifup-iucv
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
12
s390x Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On: 530577
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2009-06-21 14:31 EDT by Steffen Maier
Modified: 2014-03-16 23:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 16:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steffen Maier 2009-06-21 14:31:59 EDT
Description of problem:
S390 network devices of type NETIUCV are purely virtual and have no representation on any bus. Hence there is no way of loading the driver module automatically by means of modaliases. Also aliases by means of modprobe.conf are no longer usual, so /etc/sysconfig/network-scripts/ifup-iucv cannot even use the is_available function to load the corresponding device driver.

Version-Release number of selected component (if applicable):
initscripts-8.95-1.s390x

How reproducible:
Generate your /etc/sysconfig/network-scripts/ifcfg-iucv0 of choice and the device won't come up (using network service).

Additional info:
/etc/sysconfig/network-scripts/ifup-iucv tries to write to /sys/bus/iucv/drivers/netiucv/connection in order to instantiate such a purely virtual NETIUCV network device. However, the driver module netiucv already needs to have been loaded in order for this sysfs path to exist. Please add a quiet modprobe for netiucv before writing to sysfs and everything will work fine.

This is similar to bug 475721-"[rhel5.3] Alias ctc and iucv interfaces doesn't
work , devices not able to group on-boot" on RHEL 5.
Comment 1 Bill Nottingham 2009-06-22 13:02:32 EDT
Why not just build it in, then?
Comment 2 Bill Nottingham 2009-06-22 13:03:31 EDT
Also, last I heard, iucv was deprecated and unsupported in enterprise releases such as RHEL 5; perhaps it should just be removed?
Comment 3 Steffen Maier 2009-06-23 08:40:06 EDT
Netiucv is deprecated, yes. Still, users may need it to work as a migration path to some more recent network technology. Building the driver into the kernel seems like a bad idea considering that it's deprecated and that it should only take memory when such devices are really in use.
Comment 4 IBM Bug Proxy 2009-10-19 18:50:56 EDT
------- Comment From kumarr@linux.ibm.com 2009-10-19 18:49 EDT-------
Mirroring...
Comment 5 Hendrik Brueckner 2009-10-23 10:54:45 EDT
Opened a new bugzilla to turn off the netiucv device driver in fedora release.
See bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=530577
Comment 7 Hendrik Brueckner 2009-10-27 13:13:44 EDT
Bill,

I took a look at commit "Remove IUCV support" http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=9be11466392c3e285571a347b578681ddb3e230a

I wonder why the commit does not remove the references to ifup-iucv in the initscripts.spec?
Comment 8 Bill Nottingham 2009-10-27 14:33:24 EDT
Because I forgot it. Thanks, good catch.
Comment 9 Bug Zapper 2009-11-16 05:17:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bill Nottingham 2010-01-12 16:06:12 EST
This landed in F-12 final.

Note You need to log in before you can comment on or make changes to this bug.