Bug 507218 - Volume shifts unexpectedly
Volume shifts unexpectedly
Status: CLOSED DUPLICATE of bug 488532
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 14:41 EDT by Brent Holden
Modified: 2009-07-09 03:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-09 03:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test with totem (1019.82 KB, application/octet-stream)
2009-06-21 14:41 EDT, Brent Holden
no flags Details
test with rhythmbox (599.94 KB, application/octet-stream)
2009-06-21 14:41 EDT, Brent Holden
no flags Details

  None (edit)
Description Brent Holden 2009-06-21 14:41:15 EDT
Created attachment 348810 [details]
test with totem

Description of problem:

I would expect to set the volume at a certain percentage and have each player play music at that volume.  In both cases, with totem and rhythmbox, pulseaudio will adjust the volume +12% just before playing the track, and re-adjust after the track finishes back to the original preset volume.  This holds true for multiple tracks in the same playlist.


Version-Release number of selected component (if applicable):

[brent@osiris ~]$ rpm -qa | grep pulseaudio
wine-pulseaudio-1.1.18-1.fc11.i586
pulseaudio-module-gconf-0.9.15-14.fc11.x86_64
pulseaudio-libs-0.9.15-14.fc11.i586
pulseaudio-module-bluetooth-0.9.15-14.fc11.x86_64
pulseaudio-libs-0.9.15-14.fc11.x86_64
pulseaudio-utils-0.9.15-14.fc11.x86_64
xine-lib-pulseaudio-1.1.16.3-2.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-14.fc11.x86_64
alsa-plugins-pulseaudio-1.0.18-3.fc11.x86_64
pulseaudio-module-x11-0.9.15-14.fc11.x86_64
pulseaudio-0.9.15-14.fc11.x86_64


How reproducible:

Open music content with totem or rhythmbox

  
Actual results:

Volume changes during playback, then resumes original setting when completed.


Expected results:

Playback uses volume setting and does not change it.
Comment 1 Brent Holden 2009-06-21 14:41:46 EDT
Created attachment 348811 [details]
test with rhythmbox
Comment 2 Michael Cronenworth 2009-06-29 23:43:37 EDT
I'm seeing the exact same issue.

We should add that Totem is actually controlling the *system* volume instead of just its volume. How is this possible? Isn't PulseAudio designed so that malicious apps can't hijack audio settings?
Comment 3 Michael Schwendt 2009-07-09 03:39:21 EDT

*** This bug has been marked as a duplicate of bug 488532 ***

Note You need to log in before you can comment on or make changes to this bug.