Bug 507226 - qemu windows vista guest does not see the sound card
qemu windows vista guest does not see the sound card
Status: CLOSED DUPLICATE of bug 508317
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 16:06 EDT by Stephen Adler
Modified: 2009-08-07 08:40 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 08:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cut and past from /var/log/libvirt.log (545 bytes, application/octet-stream)
2009-07-04 12:12 EDT, Stephen Adler
no flags Details
cut and past from .virt-manager/virt-manager.log (7.15 KB, application/octet-stream)
2009-07-04 12:13 EDT, Stephen Adler
no flags Details
screen shot of my virtual windows desktop (125.79 KB, image/jpeg)
2009-07-04 12:14 EDT, Stephen Adler
no flags Details

  None (edit)
Description Stephen Adler 2009-06-21 16:06:06 EDT
Description of problem:

Sound device not detected under vista

Version-Release number of selected component (if applicable):


How reproducible:

every time


Steps to Reproduce:
1.
2.
3.

Run the virtualization guest (it's windows vista) and windows vista does not see the sound card.
  
Actual results:


Expected results:

vista should see the sound card

Additional info:
Comment 1 Mark McLoughlin 2009-06-22 08:11:20 EDT
See https://fedoraproject.org/wiki/Reporting_virtualization_bugs

Please include:

  - The version numbers of virt-manager, libvirt, qemu-kvm
  - ~/.virt-manager/virt-manager.log
  - /var/log/libvirt/qemu/$guest.log

This is probably caused by sound devices being disabled in the guest if SELinux is enabled in the host:

  https://bugzilla.redhat.com/show_bug.cgi?id=477955#c15
Comment 2 Stephen Adler 2009-07-04 12:12:10 EDT
Created attachment 350494 [details]
cut and past from /var/log/libvirt.log
Comment 3 Stephen Adler 2009-07-04 12:13:02 EDT
Created attachment 350495 [details]
cut and past from .virt-manager/virt-manager.log
Comment 4 Stephen Adler 2009-07-04 12:14:40 EDT
Created attachment 350496 [details]
screen shot of my virtual windows desktop
Comment 5 Stephen Adler 2009-07-04 12:15:48 EDT
[adler@office01 ~]$ rpm -q virt-manager  libvirt qemu-kvm
virt-manager-0.7.0-5.fc11.x86_64
libvirt-0.6.2-12.fc11.x86_64
qemu-kvm-0.10.5-3.fc11.x86_64
Comment 6 Stephen Adler 2009-07-04 12:18:03 EDT
also, notice in the command line for qemu-kvm, there is no reference to sound hardware.

The virtual setup for the windows guest was created through an upgrade from fc10. I did not create a new virtual guest from scratch and then load the windows OS. That was done when my desktop was running fc10.
Comment 7 Mark McLoughlin 2009-08-07 08:40:48 EDT
Sorry for the delayed response Stephen

This sounds like bug #508317

Because of SELinux, libvirt currently disables sound cards until this feature is implemented:

  http://fedoraproject.org/wiki/Features/VirtVNCResourceTunnel

*** This bug has been marked as a duplicate of bug 508317 ***

Note You need to log in before you can comment on or make changes to this bug.