Bug 507229 - preupgrade backtrace: PUError is not defined
preupgrade backtrace: PUError is not defined
Status: CLOSED DUPLICATE of bug 504826
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 16:34 EDT by Matt Domsch
Modified: 2014-01-21 18:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 10:23:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2009-06-21 16:34:20 EDT
Description of problem:
preupgrade from F10 to F11 fails with a python backtrace.  Yes, my /boot is on a RAID1 software RAID device.

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 238, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 473, in main_preupgrade
    bootdevpath = bootpath_to_anacondapath(stage2_abs,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/dev.py", line 86, in bootpath_to_anacondapath
    raise PUError, "/boot is on RAID device %s" % bootdev
NameError: global name 'PUError' is not defined


/etc/fstab has:
/dev/md1                /                       ext3    defaults        1 1
/dev/md0                /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/swap.1			swap			swap	defaults	0 0

mount shows:
/dev/md1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/md0 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/tmp on /tmp type none (rw,bind)
/var/tmp on /var/tmp type none (rw,bind)
/home/xguest on /home/xguest type none (rw,bind)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /home/mdomsch/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mdomsch)


/etc/mdadm.conf contains:
# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root

ARRAY /dev/md0 level=raid1 num-devices=2 metadata=0.90 UUID=fd50130e:28e10010:dc87b1fe:1d6a279b
ARRAY /dev/md1 level=raid1 num-devices=2 metadata=0.90 UUID=55c51370:093f5a4a:be8520ac:0fdbc200

# cat /proc/mdstat 
Personalities : [raid1] [raid6] [raid5] [raid4] 
md0 : active raid1 sda1[0] sdb1[1]
      200704 blocks [2/2] [UU]
      
md1 : active raid1 sda2[0] sdb2[1]
      243938880 blocks [2/2] [UU]
      
unused devices: <none>



Version-Release number of selected component (if applicable):
preupgrade-1.1.0-1.fc10.noarch
Comment 1 Will Woods 2009-06-22 10:23:58 EDT

*** This bug has been marked as a duplicate of bug 504826 ***

Note You need to log in before you can comment on or make changes to this bug.