Bug 507261 - Package building strategy is inconsistent between sazanami fonts and IPA fonts
Package building strategy is inconsistent between sazanami fonts and IPA fonts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ipa-gothic-fonts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 22:26 EDT by Takanori MATSUURA
Modified: 2009-06-22 02:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 22:45:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takanori MATSUURA 2009-06-21 22:26:48 EDT
Description of problem:
Now sazanami-fonts-common, sazanami-gothic-fonts, and sazanami-mincho-fonts packages are generated by single sazanami-fonts SRPM package.  Other hand, ipa-gothic-fonts, ipa-mincho-fonts, ipa-pgothic-fonts, and ipa-pmincho-fonts are generated by separated SRPMs.

I suppose kinds of bundled files between two font families are not different.
So all IPA fonts should be generated from single SRPM package.
Comment 1 Akira TAGOH 2009-06-21 22:45:48 EDT
The main reason why those SRPMs are packaged separately or all together is whether or not upstream ships it separately. and basically these 4 IPA fonts are different font families. thus, it's not the certain reason to contain multiple tarballs from upstream into one SRPM.
Comment 2 Takanori MATSUURA 2009-06-21 23:56:58 EDT
But upstream calls these four fonts as "IPA font" and they also provide 4 fonts package.  So I think they are one family.

IPA says at http://ossipedia.ipa.go.jp/ipafont/fontspec.html
IPA Font provides totally four fonts: Mincho style, Gothic (Sans serif) style and fixed width style and proportional style for each.

I suppose this follows four fonts are belong to the one "IPA font" family.
Comment 3 Akira TAGOH 2009-06-22 00:21:50 EDT
From the definition of font family in our policy http://fedoraproject.org/wiki/Fonts_packaging_policy

It doesn't meet the requirements.
Comment 4 Takanori MATSUURA 2009-06-22 02:07:09 EDT
(In reply to comment #3)

Hmm, I can now see both "4 fonts package" and separate zip archive are available from the official site.  I have never found separate zip archives in early time when IPA font 00301 has been released.

In this case, do we have to separate ghostscript files if we will fix bug 507262 with my suggestion?
It's too inconvenience.


Number 1 of "Package layout for fonts" in the URL mentioned in comment #3 should be updated like the following:

Fonts released upstream in separate archives MUST be packaged in separate source packages (src.rpm), unless they belong to the same font family. If fonts released upstream are also released as a merged archive, this rule will not applied.
Comment 5 Nicolas Mailhot 2009-06-22 02:27:32 EDT
(In reply to comment #4)

> Number 1 of "Package layout for fonts" in the URL mentioned in comment #3
> should be updated like the following:
> 
> Fonts released upstream in separate archives MUST be packaged in separate
> source packages (src.rpm), unless they belong to the same font family. If fonts
> released upstream are also released as a merged archive, this rule will not
> applied.

Due to how rpm dependency resolution work that would make impossible to implement multi-criterium font search & auto-installation (whichi is a mid-term Fedora goal). So I would oppose this change (of course you're free to try your luck FPC and FESCO side)

Also those fonts clearly belong do different font families as per Microsoft WWS specs so trying to join them will only result in pain mid-term. As Adobe's Thomas Phinney wrote WWS is essentially making font naming CSS compatible (you want them to work in browsers, right?)
http://blogs.msdn.com/text/attachment/2249036.ashx
http://blogs.adobe.com/typblography/typotechnica2007/Font%20names.pdf

Your main problem seems to be ghostscript requires a separate set of configuration files than the rest of the system. I suggest you spend your energy convinving the ghostscript people to use fontconfig like everyone else to find fonts. That will fix any future problem of this kind.

Note You need to log in before you can comment on or make changes to this bug.