Bug 507275 - gettext FTBS: tests "error while loading shared libraries"
gettext FTBS: tests "error while loading shared libraries"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 01:37 EDT by Jens Petersen
Modified: 2009-06-24 04:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 04:43:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-06-22 01:37:44 EDT
Description of problem:
gettext is not building in rawhide:

/builddir/build/BUILD/gettext-0.17/gettext-tools/src/.libs/lt-xgettext: error while loading shared libraries: libgettextsrc-0.17.so: cannot open shared object file: No such file or directory
FAIL: lang-perl-2
/builddir/build/BUILD/gettext-0.17/gettext-tools/src/.libs/lt-xgettext: error while loading shared libraries: libgettextsrc-0.17.so: cannot open shared object file: No such file or directory
FAIL: lang-php
/builddir/build/BUILD/gettext-0.17/gettext-tools/src/.libs/lt-xgettext: error while loading shared libraries: libgettextsrc-0.17.so: cannot open shared object file: No such file or directory
FAIL: lang-po
/builddir/build/BUILD/gettext-0.17/gettext-tools/src/.libs/lt-xgettext: error while loading shared libraries: libgettextsrc-0.17.so: cannot open shared object file: No such file or directory
FAIL: lang-rst
=======================
314 of 314 tests failed
(13 tests were not run)
=======================
Comment 2 Jens Petersen 2009-06-22 01:40:23 EDT
Karsten, would you have any idea why this might be happening in rawhide?
Comment 3 Mamoru TASAKA 2009-06-22 03:05:15 EDT
Perhaps the cause is:

---------------------------------------------------------------------
make[1]: Entering directory `/builddir/build/BUILD/gettext-0.17/gettext-runtime'
cd . && ../build-aux/fixaclocal /bin/sh /builddir/build/BUILD/gettext-0.17/build-aux/missing --run aclocal-1.10 -I m4 -I ../autoconf-lib-link/m4 -I ../m4 -I gnulib-m4
/builddir/build/BUILD/gettext-0.17/build-aux/missing: line 52: aclocal-1.10: command not found
WARNING: `aclocal-1.10' is missing on your system.  You should only need it if
         you modified `acinclude.m4' or `configure.ac'.  You might want
         to install the `Automake' and `Perl' packages.  Grab them from
         any GNU archive site.
cd . && /bin/sh /builddir/build/BUILD/gettext-0.17/build-aux/missing --run autoconf
 cd . && /bin/sh /builddir/build/BUILD/gettext-0.17/build-aux/missing --run automake-1.10 --gnu 
/builddir/build/BUILD/gettext-0.17/build-aux/missing: line 52: automake-1.10: command not found
WARNING: `automake-1.10' is missing on your system.  You should only need it if
         you modified `Makefile.am', `acinclude.m4' or `configure.ac'.
         You might want to install the `Automake' and `Perl' packages.
         Grab them from any GNU archive site.
---------------------------------------------------------------------

When gettext-0.17-11.fc12 was rebuilt, automake was 1.10.2-3.
Now rawhide has 1.11-2.fc12
Comment 4 Mamoru TASAKA 2009-06-22 03:47:41 EDT
Very quick workaround:
----------------------------------------------------------
%prep
%setup -q
%patch5 -p0 -b .5-open-args~
%patch6 -p0 -b .6-autopoint~
%patch7 -p0 -b .rpathFix~
%patch8 -p0 -b .unicode~

grep -rl '1\.10' . | grep -v html | grep -v ChangeLog | xargs sed -i -e 's|1\.10|1.11|'
----------------------------------------------------------
http://koji.fedoraproject.org/koji/taskinfo?taskID=1428812
Comment 5 Jens Petersen 2009-06-24 04:43:33 EDT
Thanks Tasaka-san for spotting that.

Wish autotools would just fail in this case... :-|

I pushed a build to rawhide which just run autogen.sh: I hope that is good enough.

Note You need to log in before you can comment on or make changes to this bug.