Bug 507277 - (RHEL 5.4 Alpha I386) error log when using aplay to play some audio files on Piketon + Havendale/Lynnfield SDVs
(RHEL 5.4 Alpha I386) error log when using aplay to play some audio files on ...
Status: CLOSED DUPLICATE of bug 509526
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: alsa-lib (Show other bugs)
5.4
i686 Linux
low Severity medium
: alpha
: ---
Assigned To: Jaroslav Kysela
desktop-bugs@redhat.com
:
Depends On:
Blocks: 480792
  Show dependency treegraph
 
Reported: 2009-06-22 02:02 EDT by DongpoLiu
Modified: 2009-08-18 22:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 22:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DongpoLiu 2009-06-22 02:02:12 EDT
we can get some error log when run following commands:
[root@osve-hp initial]#aplay  /usr/share/sounds/*.*  
ALSA lib pcm_direct.c:866:(snd1_pcm_direct_initialize_slave) snd_pcm_hw_params_any failed
ALSA lib pcm_dmix.c:1020:(snd_pcm_dmix_open) unable to initialize slave
aplay: main:583: audio open error: Invalid argument

we can not heard sound from earphone.

OS is RHEL 5.4 Alpha
Kernel is Linux osve-hp 2.6.18-154.el5 #1 SMP Wed Jun 17 17:51:55 EDT 2009 i686 i686 i386 GNU/Linux
HW is Piketon + Havendale SDV
Comment 1 DongpoLiu 2009-06-23 01:42:24 EDT
no such issue with x86_64 RHEL 5.4 Alpha
Comment 2 Jane Lv 2009-06-23 01:57:34 EDT
Piketon platform has IbexPeak chipset.
Comment 3 DongpoLiu 2009-06-26 04:46:53 EDT
we can also see almost the same issue at Piketon + Lynnfiled SDV (IbexPeak chipset). 

Details is as follows:
[root@osve-lp ~]# aplay  /usr/share/sounds/*.wav 
ALSA lib pcm_direct.c:866:(snd1_pcm_direct_initialize_slave)
snd_pcm_hw_params_any failed
ALSA lib pcm_dmix.c:1020:(snd_pcm_dmix_open) unable to initialize slave
aplay: main:583: audio open error: Invalid argument

[root@osve-lp ~]# lsmod | grep snd 
snd_hda_intel         423953  1 
snd_seq_dummy           7877  0 
snd_seq_oss            32577  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11725  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42817  0 
snd_mixer_oss          19009  1 snd_pcm_oss
snd_pcm                72133  2 snd_hda_intel,snd_pcm_oss
snd_timer              24517  2 snd_seq,snd_pcm
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
snd_hwdep              12869  1 snd_hda_intel
snd                    55749  11
snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              11553  1 snd

[root@osve-lp ~]# uname -a 
Linux osve-lp 2.6.18-154.el5 #1 SMP Wed Jun 17 17:51:55 EDT 2009 i686 i686 i386
GNU/Linux


in dmesg, we can see hda_codec: Unknown model for ALC883, trying auto-probe
from BIOS...
Comment 4 Jaroslav Kysela 2009-07-08 03:59:18 EDT
This bug might be similar to bug#509526 . Is x86_64 installation affected, too?
Comment 5 DongpoLiu 2009-07-08 22:07:12 EDT
Lynnfield with RHEL 5.4 Beta x86_64 OS, we can get audio output although some issue with back pannel.
Comment 6 John Villalovos 2009-08-18 22:18:17 EDT

*** This bug has been marked as a duplicate of bug 509526 ***

Note You need to log in before you can comment on or make changes to this bug.