This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 507290 - gnome-terminal does not work with remote connection
gnome-terminal does not work with remote connection
Status: CLOSED DUPLICATE of bug 484134
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 04:08 EDT by Piergiorgio Sartor
Modified: 2009-08-04 09:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-04 09:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2009-06-22 04:08:10 EDT
Description of problem:
Connecting to an F-11 PC starting gnome-terminal does not work.

Version-Release number of selected component (if applicable):
gnome-terminal-2.26.1-1.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1.
From some PC (either with F-10 or WinXP with Xming):

ssh -X -Y remote-fedora-11-PC -l user gnome-terminal
  
Actual results:
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib:  extension "Generic Event Extension" missing on display "localhost:10.0".
Failed to contact the GConf daemon; exiting.

Expected results:
Connection should be established, like for other applications, and the gnome-terminal should start.

Additional info:
This works with firefox, thunderbird, roxterm, evolution, etc., even if the first Xlib lines are printed (but not the GConf error).

Also, gnome-terminal does not work (same error) if it is started after the connection is established, i.e. ssh first, then, at bash prompt, gnome-terminal.

Please, note that this is a showstopper for the F-11 upgrade.

Thanks,

piergiorgio
Comment 1 Ben Greear 2009-06-29 17:37:09 EDT
This happens on Fedora 10 as well.

I have a similar problem trying to start gnome-terminal from a process running as user root when logged in to X as another user.  (I'm setting DISPLAY so that gnome-terminal should actually show up on another machine.)  Seems Ubuntu folks and others have the same problem:

https://bugs.launchpad.net/ubuntu/+source/gconf2/+bug/328575

This is a very annoying bug.
Comment 2 Piergiorgio Sartor 2009-07-10 08:00:51 EDT
Any news on this? Some comments? Feedback?

Did anybody looked into it?

What about a quick patch/downgrade? Something to test?

As I mentioned already, this is a showstopper for F-11 upgrade, it would be nice to know if something is going on or we should use roxterm and forget gnome-terminal.

About comment #1, for me, in F-10, it was fine, I could connect remotely and use gnome-terminal without problems.

Thanks again,

piergiorgio
Comment 3 Yanko Kaneti 2009-08-04 09:43:17 EDT

*** This bug has been marked as a duplicate of bug 484134 ***

Note You need to log in before you can comment on or make changes to this bug.