Bug 50731 - Autopartition fails after second time
Autopartition fails after second time
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 13:38 EDT by William Engler
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 13:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description William Engler 2001-08-02 13:38:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
System has vfat partition in /dev/hda1  When using the autopartition feature,using the remove all linux partitions and then going back and trying 
it again, fails to find whichever partition / was put on the first time.

How reproducible:
Always

Steps to Reproduce:
1. Go through generic install, choose any type of system (I tried Workstation, Server and Laptop)
2. Select autopartition
3. Select "Remove all Linux Partitions" (I tried this both with and without Linux partitions existing on the drive) and then ok and Yes
4. Note the mount point of / and then select  "Back"
5. Select "Remove all Linux Partitions" and then Ok and the Yes
6. Look at the error message
	

Actual Results:  Dialogue box (this one was the result from the workstation install option)
Title: Requested Partition Does Not Exist
"Unable to locate partition hda3 to use for /.
Press OK to reboot your system."
Button: OK

Expected Results:  A listing of partitions, sizes and mount points.

Additional info:

Windows 98(r) is also installed on hda1
Comment 1 Jeremy Katz 2001-08-02 16:36:58 EDT
This is already fixed in our internal trees.

Note You need to log in before you can comment on or make changes to this bug.