Bug 507353 - Firefox doesn't cache <video> elements, wastes users' precious bandwidth
Firefox doesn't cache <video> elements, wastes users' precious bandwidth
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 09:34 EDT by Richard Schwarting
Modified: 2009-06-26 05:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 04:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 462378 None None None Never

  None (edit)
Description Richard Schwarting 2009-06-22 09:34:08 EDT
Description of problem:

https://bugzilla.mozilla.org/show_bug.cgi?id=462378 
This bug (closed upstream) appears to apply to Fedora 11's Firefox.

Video elements are being redownloaded every time I revisit a page with one.
e.g. http://www.0xdeadbeef.com/weblog/?p=1321

I'm watching my bandwidth use each time and watch it buffer up, and this is becoming an expensive problem.  (So is having it autobuffer/autodownload, but that's for a different bug.)

Version-Release number of selected component (if applicable):
3.5b4

How reproducible:
Always. 

Steps to Reproduce:
1. visit http://www.0xdeadbeef.com/weblog/?p=1321
2. refresh 
3. monitor your bandwidth use, the element's buffering
  
Actual results:
* it is rebuffering, consuming MBs.  Go to a planet multiple times a day where people are using these by default, and can quickly use between 50-100MB a visit!  

Expected results:
* it should cache them.  

Additional info:
* I can't actually test Mozilla head because the remaining bandwidth in my plan is too little for the month and it gets quite expensive when you go over :|
Comment 1 Martin Stransky 2009-06-22 09:52:16 EDT
Can you test it with official linux binaries downloaded from mozilla.org?
Comment 2 Richard Schwarting 2009-06-22 10:27:34 EDT
Remotely logged into a friend's computer (cheaper than testing locally right now :) and interestingly, it's not caching them using 3.5rc2, but it's not autobuffering them like the version on my Fedora 11 install is.  So, it's not much of a problem.  Instead of downloading the entire thing, it's only buffering a few hundred KB at the start.  

I filed bug 507358 a short while ago noting the version from Fedora on my PC  auto-downloading the entire thing already :(

I'd use rc2 in its place, but sadly that crashed 3 times in the 5 minutes I tested this :)
Comment 3 Matěj Cepl 2009-06-25 15:36:42 EDT
Yup, exactly as reporter said. We are downloading and downloading and
downloading. I am thankful that I have unlimited ADSL ;-)
Comment 4 Martin Stransky 2009-06-26 03:54:37 EDT
From the page at http://macslow.net/?p=320#comment-176351, I can reproduce the issue with official mozilla binaries (3.5 pre aka RC candidate). So I suppose to move this bug upstream...
Comment 5 Matěj Cepl 2009-06-26 04:34:19 EDT
We have reopened the upstream bug.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 6 Richard Schwarting 2009-06-26 05:02:55 EDT
Thank you :)

Note You need to log in before you can comment on or make changes to this bug.