Bug 507361 - Kernel oops (2.6.31-0.21.rc0.git18.fc12.i586)
Kernel oops (2.6.31-0.21.rc0.git18.fc12.i586)
Status: CLOSED DUPLICATE of bug 507161
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 10:04 EDT by Igor Zubkov
Modified: 2009-06-29 19:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 19:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "dmesg" (122.15 KB, text/plain)
2009-06-22 12:41 EDT, Tom London
no flags Details

  None (edit)
Description Igor Zubkov 2009-06-22 10:04:51 EDT
Description of problem:
Kernel oops

Version-Release number of selected component (if applicable):
$ uname -a
Linux localhost.localdomain 2.6.31-0.21.rc0.git18.fc12.i586 #1 SMP Sun Jun 21 23:40:44 EDT 2009 i686 i686 i386 GNU/Linux
$ 

$ rpm -qa | grep kernel
kernel-firmware-2.6.31-0.21.rc0.git18.fc12.noarch
kernel-2.6.29.4-167.fc11.i586
kernel-firmware-2.6.31-0.17.rc0.git15.fc12.noarch
kernel-devel-2.6.29.4-167.fc11.i586
kernel-devel-2.6.31-0.17.rc0.git15.fc12.i586
kernel-2.6.31-0.21.rc0.git18.fc12.i586
kerneloops-0.12-5.fc11.i586
kernel-devel-2.6.31-0.15.rc0.git14.fc12.i586
kernel-headers-2.6.31-0.17.rc0.git15.fc12.i586
$ 


How reproducible:
Update kernel to 2.6.31-0.21.rc0.git18.fc12.i586 build

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Kernel oops.

Expected results:
No kernel oops.:)

dmesg attached.
Comment 1 Igor Zubkov 2009-06-22 10:13:08 EDT
Kernel failure message 1:
------------[ cut here ]------------
WARNING: at lib/list_debug.c:26 __list_add+0x35/0x79()
Hardware name:  
list_add corruption. next->prev should be prev (df8304c4), but was c1c7f668. (next=c1c8c9f8).
Modules linked in: hfsplus hfs vfat fat nls_utf8 udf crc_itu_t fuse sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 dm_multipath uinput ppdev pcspkr serio_raw snd_cmipci i2c_i801 i2c_core snd_pcm snd_page_alloc snd_opl3_lib snd_timer snd_hwdep snd_mpu401_uart snd_rawmidi snd_seq_device iTCO_wdt snd iTCO_vendor_support soundcore ne2k_pci 8390 ns558 gameport parport_pc parport floppy ata_generic pata_acpi [last unloaded: hfsplus]
Pid: 4870, comm: yum Tainted: G        W  2.6.31-0.21.rc0.git18.fc12.i586 #1
Call Trace:
 [<c0443a0e>] warn_slowpath_common+0x75/0x9d
 [<c05fb904>] ? __list_add+0x35/0x79
 [<c0443a9f>] warn_slowpath_fmt+0x34/0x48
 [<c05fb904>] __list_add+0x35/0x79
 [<c04f0c0c>] mem_cgroup_add_lru_list+0x54/0x7b
 [<c04c8567>] add_page_to_lru_list+0x4b/0x62
 [<c04c8a64>] activate_page+0x88/0xe0
 [<c04c8af3>] mark_page_accessed+0x37/0x5a
 [<c04c1c7e>] generic_file_aio_read+0x323/0x50d
 [<c04f41fe>] do_sync_read+0xbe/0x10a
 [<c044a098>] ? do_softirq+0x5b/0x7f
 [<c045b78a>] ? autoremove_wake_function+0x0/0x55
 [<c05ae52e>] ? security_file_permission+0x23/0x36
 [<c04f42ef>] ? rw_verify_area+0xa5/0xd8
 [<c04f4140>] ? do_sync_read+0x0/0x10a
 [<c04f4989>] vfs_read+0x9c/0x10c
 [<c04f4a63>] sys_pread64+0x6a/0x93
 [<c0403a5c>] syscall_call+0x7/0xb
---[ end trace 1105095b15ad6bee ]---
Comment 2 Tom London 2009-06-22 12:41:13 EDT
Created attachment 348942 [details]
output of "dmesg"

I'm seeing this as well on Thinkpad X200 (x86_64).  Have 46 of them....

------------[ cut here ]------------
WARNING: at lib/list_debug.c:26 __list_add+0x4c/0xa7()
Hardware name: 74585FU
list_add corruption. next->prev should be prev (ffff88013bc60510), but was ffff880138c911f8. (next=ffff880138c91748).
Modules linked in: cryptd aes_x86_64 aes_generic vfat fat fuse ipt_MASQUERADE iptable_nat nf_nat bridge stp llc sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput arc4 ecb snd_hda_codec_conexant btusb snd_hda_intel iwlagn snd_hda_codec bluetooth iwlcore snd_hwdep snd_pcm mac80211 usblp usb_storage snd_timer thinkpad_acpi pcspkr i2c_i801 hwmon e1000e cfg80211 snd iTCO_wdt wmi soundcore rfkill iTCO_vendor_support snd_page_alloc i915 drm i2c_algo_bit video output i2c_core [last unloaded: microcode]
Pid: 30, comm: kswapd0 Not tainted 2.6.31-0.21.rc0.git18.fc12.x86_64 #1
Call Trace:
 [<ffffffff81062f59>] warn_slowpath_common+0x8d/0xbb
 [<ffffffff81063014>] warn_slowpath_fmt+0x50/0x66
 [<ffffffff81104165>] ? shrink_list+0x4e4/0x6c2
 [<ffffffff81278405>] __list_add+0x4c/0xa7
 [<ffffffff811381ff>] mem_cgroup_add_lru_list+0x78/0x9f
 [<ffffffff81104249>] shrink_list+0x5c8/0x6c2
 [<ffffffff81104620>] shrink_zone+0x2dd/0x38a
 [<ffffffff81104fa9>] kswapd+0x4cc/0x682
 [<ffffffff81102dfd>] ? isolate_pages_global+0x0/0x26c
 [<ffffffff8107f577>] ? autoremove_wake_function+0x0/0x5f
 [<ffffffff81104add>] ? kswapd+0x0/0x682
 [<ffffffff8107f129>] kthread+0xa5/0xad
 [<ffffffff8101412a>] child_rip+0xa/0x20
 [<ffffffff81013a90>] ? restore_args+0x0/0x30
 [<ffffffff8107f084>] ? kthread+0x0/0xad
 [<ffffffff81014120>] ? child_rip+0x0/0x20
---[ end trace 0604998f3bf37155 ]---
------------[ cut here ]------------
WARNING: at lib/list_debug.c:26 __list_add+0x4c/0xa7()
Hardware name: 74585FU
list_add corruption. next->prev should be prev (ffff88013bc604e0), but was ffff880138cd5100. (next=ffff880138cd50b0).
Modules linked in: cryptd aes_x86_64 aes_generic vfat fat fuse ipt_MASQUERADE iptable_nat nf_nat bridge stp llc sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput arc4 ecb snd_hda_codec_conexant btusb snd_hda_intel iwlagn snd_hda_codec bluetooth iwlcore snd_hwdep snd_pcm mac80211 usblp usb_storage snd_timer thinkpad_acpi pcspkr i2c_i801 hwmon e1000e cfg80211 snd iTCO_wdt wmi soundcore rfkill iTCO_vendor_support snd_page_alloc i915 drm i2c_algo_bit video output i2c_core [last unloaded: microcode]
Pid: 30, comm: kswapd0 Tainted: G        W  2.6.31-0.21.rc0.git18.fc12.x86_64 #1
Call Trace:
 [<ffffffff81062f59>] warn_slowpath_common+0x8d/0xbb
 [<ffffffff81063014>] warn_slowpath_fmt+0x50/0x66
 [<ffffffff81278405>] __list_add+0x4c/0xa7
 [<ffffffff8111a994>] ? page_check_address+0x102/0x174
 [<ffffffff811381ff>] mem_cgroup_add_lru_list+0x78/0x9f
 [<ffffffff81102d41>] move_active_pages_to_lru+0xdb/0x197
 [<ffffffff81103c18>] ? shrink_active_list+0x230/0x299
 [<ffffffff81103c18>] ? shrink_active_list+0x230/0x299
 [<ffffffff81103c18>] ? shrink_active_list+0x230/0x299
 [<ffffffff81103c18>] ? shrink_active_list+0x230/0x299
 [<ffffffff81103c4f>] shrink_active_list+0x267/0x299
 [<ffffffff81102d9e>] ? move_active_pages_to_lru+0x138/0x197
 [<ffffffff81103d35>] shrink_list+0xb4/0x6c2
 [<ffffffff8109565e>] ? print_lock_contention_bug+0x2a/0x106
 [<ffffffff8126f6fa>] ? __up_read+0x2d/0xaa
 [<ffffffff8126f6fa>] ? __up_read+0x2d/0xaa
 [<ffffffff8126f6fa>] ? __up_read+0x2d/0xaa
 [<ffffffff81093b6e>] ? trace_hardirqs_on_caller+0x32/0x175
 [<ffffffff81093cd1>] ? trace_hardirqs_on+0x20/0x36
 [<ffffffff81104620>] shrink_zone+0x2dd/0x38a
 [<ffffffff81104fa9>] kswapd+0x4cc/0x682
 [<ffffffff81102dfd>] ? isolate_pages_global+0x0/0x26c
 [<ffffffff8107f577>] ? autoremove_wake_function+0x0/0x5f
 [<ffffffff81104add>] ? kswapd+0x0/0x682
 [<ffffffff8107f129>] kthread+0xa5/0xad
 [<ffffffff8101412a>] child_rip+0xa/0x20
 [<ffffffff81013a90>] ? restore_args+0x0/0x30
 [<ffffffff8107f084>] ? kthread+0x0/0xad
 [<ffffffff81014120>] ? child_rip+0x0/0x20
---[ end trace 0604998f3bf37156 ]---
------------[ cut here ]------------
WARNING: at lib/list_debug.c:26 __list_add+0x4c/0xa7()
Hardware name: 74585FU
list_add corruption. next->prev should be prev (ffff88013bc60510), but was ffff880138c7ce88. (next=ffff880138c7ced8).
Modules linked in: cryptd aes_x86_64 aes_generic vfat fat fuse ipt_MASQUERADE iptable_nat nf_nat bridge stp llc sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput arc4 ecb snd_hda_codec_conexant btusb snd_hda_intel iwlagn snd_hda_codec bluetooth iwlcore snd_hwdep snd_pcm mac80211 usblp usb_storage snd_timer thinkpad_acpi pcspkr i2c_i801 hwmon e1000e cfg80211 snd iTCO_wdt wmi soundcore rfkill iTCO_vendor_support snd_page_alloc i915 drm i2c_algo_bit video output i2c_core [last unloaded: microcode]
Pid: 30, comm: kswapd0 Tainted: G        W  2.6.31-0.21.rc0.git18.fc12.x86_64 #1
Call Trace:
 [<ffffffff81062f59>] warn_slowpath_common+0x8d/0xbb
 [<ffffffff81063014>] warn_slowpath_fmt+0x50/0x66
 [<ffffffff81104165>] ? shrink_list+0x4e4/0x6c2
 [<ffffffff81278405>] __list_add+0x4c/0xa7
 [<ffffffff811381ff>] mem_cgroup_add_lru_list+0x78/0x9f
 [<ffffffff81104249>] shrink_list+0x5c8/0x6c2
 [<ffffffff81104620>] shrink_zone+0x2dd/0x38a
 [<ffffffff81104fa9>] kswapd+0x4cc/0x682
 [<ffffffff81102dfd>] ? isolate_pages_global+0x0/0x26c
 [<ffffffff8107f577>] ? autoremove_wake_function+0x0/0x5f
 [<ffffffff81104add>] ? kswapd+0x0/0x682
 [<ffffffff8107f129>] kthread+0xa5/0xad
 [<ffffffff8101412a>] child_rip+0xa/0x20
 [<ffffffff81013a90>] ? restore_args+0x0/0x30
 [<ffffffff8107f084>] ? kthread+0x0/0xad
 [<ffffffff81014120>] ? child_rip+0x0/0x20
---[ end trace 0604998f3bf37157 ]---
------------[ cut here ]------------

Attaching complete "dmesg"
Comment 3 Alexey Torkhov 2009-06-26 05:55:36 EDT
This seem to be a duplicate of bug 507161.
Comment 4 Chuck Ebbert 2009-06-29 19:22:34 EDT

*** This bug has been marked as a duplicate of bug 507161 ***

Note You need to log in before you can comment on or make changes to this bug.