Bug 507374 - "libguestfs: error: do_mount_vfs: /dev/sda1: No such file or directory" even though /dev/sda1 exists
"libguestfs: error: do_mount_vfs: /dev/sda1: No such file or directory" even ...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 10:45 EDT by Richard W.M. Jones
Modified: 2010-03-27 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 06:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-06-22 10:45:57 EDT
Originally reported by Marek Goldmann.

Full logs at: http://gist.github.com/133998

><fs> list-partitions
sock_write_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x2
sock_write_event: writing 28 bytes ...
sock_write_event: wrote 28 bytes
sock_write_event: done writing, calling send_cb
sock_read_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x1
sock_read_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x1
/dev/sda1
><fs> mount /dev/sda1 /
sock_write_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x2
sock_write_event: writing 52 bytes ...
sock_write_event: wrote 52 bytes
sock_write_event: done writing, calling send_cb
guestfsd: error: do_mount_vfs: /dev/sda1: No such file or directory
sock_read_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x1
sock_read_event: 0x1fbe040 g->state = 3, fd = 3, events = 0x1
libguestfs: error: do_mount_vfs: /dev/sda1: No such file or directory
Comment 1 Richard W.M. Jones 2009-06-22 11:08:01 EDT
Reportedly this happens with the following image:
http://repo.oddthesis.org/releases/jboss-cloud/1.0.0.Beta5/x86_64/management-appliance/management-appliance-1.0.0.Beta5-raw.tar.gz
Comment 2 Richard W.M. Jones 2009-06-22 11:39:35 EDT
Looks like the interesting error is:

MAKEDEV: no such group: floppy

I looked at the source for MAKEDEV[1] and if it encounters
this error, it will quit early without creating any of the
rest of the devices.

I confirmed with Marek that the floppy group is missing from
/etc/group, and also that only devices up to the point of
making the floppy devices were created.

[1] https://fedorahosted.org/MAKEDEV/browser/MAKEDEV.c
Comment 3 Richard W.M. Jones 2009-06-22 11:45:02 EDT
Potential fix, please test it.

http://git.et.redhat.com/?p=libguestfs.git;a=commitdiff;h=6f63b699aa03271468f4af9f90933e2d8dbd3db0
Comment 4 Fedora Update System 2009-06-23 05:14:50 EDT
libguestfs-1.0.51-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.51-1.fc11
Comment 5 Fedora Update System 2009-06-29 15:27:32 EDT
libguestfs-1.0.54-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.54-2.fc11
Comment 6 Fedora Update System 2009-07-02 19:26:19 EDT
libguestfs-1.0.55-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.55-1.fc11
Comment 7 Fedora Update System 2009-07-11 05:27:16 EDT
libguestfs-1.0.58-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.58-2.fc11
Comment 8 Fedora Update System 2009-07-11 13:12:38 EDT
libguestfs-1.0.54-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-07-19 06:27:49 EDT
libguestfs-1.0.58-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Richard W.M. Jones 2010-03-27 06:31:59 EDT
Long fixed, since we now use udev to create the devices.

Note You need to log in before you can comment on or make changes to this bug.