Bug 507389 - clutter-cairo is obsolete
clutter-cairo is obsolete
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: clutter (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 11:47 EDT by Peter Robinson
Modified: 2009-07-28 08:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 08:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-06-22 11:47:31 EDT
According to the following log entry in the upstream git clutter-cairo is obsolete as of clutter 0.9.x

http://git.clutter-project.org/cgit.cgi?url=clutter-cairo/commit/&id=b6a4c4bc1d2bbb6d48bda6bbc3f120f3ab6f754b

Its been replaced by stuff in clutter 0.9.x so needs to be obsoleted etc.
Comment 1 Peter Robinson 2009-07-21 05:10:48 EDT
I've marked it as a dead package in the devel cvs branch and filed the following ticket with rel-eng to block it from rawhide.

https://fedorahosted.org/rel-eng/ticket/2005
Comment 2 Peter Robinson 2009-07-21 07:47:43 EDT
Its now been blocked from F-12/rawhide. Reassigning to clutter component to have appropriate obsolete stuff added to allow a clean upgrade from F-11 and prior.
Comment 3 Itamar Reis Peixoto 2009-07-28 07:22:05 EDT
I need to add the line

obsolete: clutter-cairo 

? 

into the clutter.spec  (devel, F-11, F-10) ?
Comment 4 Peter Robinson 2009-07-28 07:45:51 EDT
(In reply to comment #3)
> I need to add the line
> 
> obsolete: clutter-cairo 

Probably something like but not 100% sure, probably worth checking the packaging guidelines:

Obsoletes: clutter-cairo < 0.9
Provides: clutter-cairo = 0.9

> into the clutter.spec  (devel, F-11, F-10) ?  

Just for devel. F-11 has clutter-cairo 0.8.x but for the 0.9.x releases of clutter* that are in rawhide this has been merged into the main clutter library so clutter-cairo is obsolete.
Comment 5 Itamar Reis Peixoto 2009-07-28 08:24:08 EDT
fixed in rawhide

http://koji.fedoraproject.org/koji/taskinfo?taskID=1550121

Note You need to log in before you can comment on or make changes to this bug.