Bug 507425 - FreeIPA on Fedora 11 Segfaults Apache
FreeIPA on Fedora 11 Segfaults Apache
Status: CLOSED DUPLICATE of bug 502133
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 14:04 EDT by Stephen Gallagher
Modified: 2009-06-23 20:10 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 20:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2009-06-22 14:04:14 EDT
Description of problem:
After setting up a FreeIPA 1.2.1 server on a clean Fedora 11 VM, all Apache child processes die with a segfault (listed in the error_log). I ran httpd under gdb to get a backtrace, attached below.

Version-Release number of selected component (if applicable):
ipa-server-1.2.1-5.fc11.i586

How reproducible:
Every time


Steps to Reproduce:
1. yum install ipa-server (pulls ipa-server-1.2.1-4 from the repos at this time)
2. run ipa-server-install (completes successfully)
3. yum update to ipa-server-1.2.1-5 from updates-testing (I pulled it straight from koji)
4. ipactl restart (look at apache error_log: constant spamming of segfaults from the children)

  
Actual results:
All apache children segfault constantly.

Expected results:
The Web UI should be started.


Additional info:

#0  0x006e5f70 in ?? ()
#1  0x00d7d23b in PR_CallOnce_stub (once=0xd93ac8, func=0xd5d750 <rng_init>) at stubs.c:438
#2  0x00d5c65a in RNG_RNGInit () at drbg.c:462
#3  0x007f9402 in RNG_RNGInit () at loader.c:834
#4  0x007dba52 in nsc_CommonInitialize (pReserved=0xbfffdf64, isFIPS=0) at pkcs11.c:2580
#5  0x007dbd1d in NSC_Initialize (pReserved=0xbfffdf64) at pkcs11.c:2710
#6  0xb7c94011 in secmod_ModuleInit (mod=0xb6a16730, alreadyLoaded=0xbfffdfc8) at pk11load.c:146
#7  0xb7c94616 in SECMOD_LoadPKCS11Module (mod=0xb6a16730) at pk11load.c:378
#8  0xb7ca79eb in SECMOD_LoadModule (
    modulespec=0xb6a170d8 " name=\"NSS Internal PKCS #11 Module\" parameters=\"configdir='/etc/httpd/alias' certPrefix='' keyPrefix='' secmod='secmod.db' flags=readOnly,passwordRequired updatedir='' updateCertPrefix='' updateKeyPr"..., parent=0xb6a13b90, recurse=1) at pk11pars.c:323
#9  0xb7ca7b73 in SECMOD_LoadModule (
    modulespec=0xb6a0ff78 "name=\"NSS Internal Module\" parameters=\"configdir='/etc/httpd/alias' certPrefix='' keyPrefix='' secmod='secmod.db' flags=readOnly,passwordRequired updatedir='' updateCertPrefix='' updateKeyPrefix='' up"..., parent=0x0, recurse=1) at pk11pars.c:338
#10 0xb7c74bd5 in nss_Init (configdir=0xb7dd6530 "/etc/httpd/alias", certPrefix=<value optimized out>, keyPrefix=0x0, secmodName=0x7046f2 "secmod.db", updateDir=0xb7d598cf "", 
    updCertPrefix=0xb7d598cf "", updKeyPrefix=0xb7d598cf "", updateID=0xb7d598cf "", updateName=0xb7d598cf "", readOnly=1, noCertDB=0, noModDB=0, forceOpen=0, noRootInit=0, optimizeSpace=0, 
    noSingleThreadedModules=0, allowAlreadyInitializedModules=0, dontFinalizeModules=0) at nssinit.c:536
#11 0xb7c751fd in NSS_Initialize (configdir=0xb7dd6530 "/etc/httpd/alias", certPrefix=0x0, keyPrefix=0x0, secmodName=0x7046f2 "secmod.db", flags=1) at nssinit.c:653
#12 0x006f7693 in nss_init_SSLLibrary (base_server=<value optimized out>) at nss_engine_init.c:198
#13 0x006f9747 in nss_init_Child (p=0xb6a18b90, base_server=0xa52598) at nss_engine_init.c:1131
#14 0x00a1cef2 in ap_run_child_init (pchild=0xb6a18b90, s=0xa52598) at /usr/src/debug/httpd-2.2.11/server/config.c:155
#15 0x00a32b28 in child_main (child_num_arg=<value optimized out>) at /usr/src/debug/httpd-2.2.11/server/mpm/prefork/prefork.c:513
#16 0x00a330a9 in make_child (s=<value optimized out>, slot=0) at /usr/src/debug/httpd-2.2.11/server/mpm/prefork/prefork.c:690
#17 0x00a3382f in ap_mpm_run (_pconf=0xa506a0, plog=0xa7e758, s=0xa52598) at /usr/src/debug/httpd-2.2.11/server/mpm/prefork/prefork.c:966
#18 0x00a0792a in main (argc=2, argv=0xbffff714) at /usr/src/debug/httpd-2.2.11/server/main.c:740
Comment 1 Stephen Gallagher 2009-06-22 15:19:07 EDT
Reassigning this bug to the NSS component. We believe that the problem exists within mod_nss rather than FreeIPA.
Comment 2 Simo Sorce 2009-06-22 15:43:35 EDT
Reassigned to mod_nss
Comment 3 Gwyn Ciesla 2009-06-23 10:08:40 EDT
Confirmed, saw this on apache sans FreeIPA, removing mod_nss fixed it.
Comment 4 Rob Crittenden 2009-06-23 20:10:07 EDT

*** This bug has been marked as a duplicate of bug 502133 ***

Note You need to log in before you can comment on or make changes to this bug.