This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 50743 - nfsutils source rpm requires user intervention during install
nfsutils source rpm requires user intervention during install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 15:12 EDT by Rick Moseley
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 23:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Moseley 2001-08-02 15:12:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
A bug was introduced to the nfsutils spec file when a delete of rpc.quotad
was added.  It turns out /sbin/rpc.quotad does not have write privileges
and when the "rm" command is used to delete it, the user is asked if they
want to indeed delete the "write-protected" file.  This is not a problem
when doing the "rpm -bi" from a command line, but when the "rpm -bi" is
issued from a shell script the install halts right at the "rm" command for
rpc.quotad.  Since no terminal is associated, the user never sees the
question and it appears the install has hung.  This command is in the spec
file and should be changed to "rm -f" so no user intervention is needed.

How reproducible:
Always

Steps to Reproduce:
1.run the command "rpm -bi nfs-utils-0.3.1-5.src.rpm"
2.wait for the script to ask the user whether they want to delete
rpc.quoated or not
3.
	

Additional info:
Comment 1 Bob Matthews 2001-08-06 11:33:02 EDT
/usr/sbin/rpc.rquotad should have 755 perms.  If the sysadmin changed the
permissions on rpc.rquotad to 555, rpm shouldn't override this.
Comment 2 Rick Moseley 2001-08-06 12:29:31 EDT
I am building the SRPM with a script that changes "buildroot" and inside the
/home/rmoseley/ELProduct/buildtree/nfsutils/usr/sbin directory the permissions
for rpc.quotad are "555" as they come out of the build part of the SRPM.  Nobody
has changed the permissions.  I do not know why the permissions are set to 555
after the build process, that is out of my control.  All I know is that coming
out of the "build" part of the nfs-utils SRPM and before getting to the
"install" part of the SRPM the permissions are set to 555 by whoever did the
"makefile".  When rpc.quotad is attempted to be deleted you get prompted about
deleting a write protected file.  We'll handle patching it here in Huntsville
before we distribute it in our Embedded Linux box product if you don't think
that is a bug.
Comment 3 Bob Matthews 2001-08-06 14:49:55 EDT
It's definitely a bug if rquotad gets installed in the build root with 555
perms.

The problem is, I can't reproduce it here.  When I perform the build, rpm
installs rpc.rquotad with perms 755.  Running rpm -bi -vv generates the
following line:

> install -m 755 -s rquotad /var/tmp/nfs-utils/root-usr/sbin/rpc.rquotad

Perhaps the umask in the shell is too restrictive?

Note You need to log in before you can comment on or make changes to this bug.