Bug 507469 - host command does not report errors with a specified server
host command does not report errors with a specified server
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 17:26 EDT by Andrew McNabb
Modified: 2013-04-30 19:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.1.0-0.2.a1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-06-22 17:26:54 EDT
Although a specific server was given on the command line, the host command fell back on the backup servers in /etc/resolv.conf instead of reporting the error from the server.  For example:

"""
amcnabb@maggie:~% host mcnabbs.org 10.0.0.10
Using domain server:
Name: 128.187.80.20
Address: 128.187.80.20#53
Aliases: 

mcnabbs.org has address 67.207.145.27
mcnabbs.org mail is handled by 5 mail.mcnabbs.org.
amcnabb@maggie:~%
"""

According to the man page for host, "server is an optional argument which is either the name or IP address of the name server that host should query instead of the server or servers listed in /etc/resolv.conf."
Comment 1 Fedora Update System 2009-06-26 22:57:33 EDT
bind-dyndb-ldap-0.1.0-0.2.a1.fc11, dnsperf-1.0.1.0-10.fc11, bind-9.6.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind-dyndb-ldap dnsperf bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6766
Comment 2 Andrew McNabb 2009-07-02 17:11:05 EDT
I did "yum --enablerepo=updates-testing update bind-dyndb-ldap dnsperf" and ran "host" and got:

host: error while loading shared libraries: liblwres.so.50: cannot open shared object file: No such file or directory

It looks like bind-libs-9.6.1-2.fc11.x86_64 has a broken symlink:

amcnabb@prodigy:~% ls -l /usr/lib64/liblwres*     
lrwxrwxrwx 1 root root    18 2009-07-02 15:06 /usr/lib64/liblwres.so.50 -> liblwres.so.50.2.0
-rwxr-xr-x 1 root root 73336 2009-06-24 08:58 /usr/lib64/liblwres.so.50.0.2

It looks like the symlink should point at liblwres.so.50.0.2 instead of liblwres.so.50.2.0.
Comment 3 Andrew McNabb 2009-07-02 17:16:36 EDT
I fixed this symlink by hand and noticed another broken symlink:

root@prodigy:/usr/lib64# ls -l libbind9*
lrwxrwxrwx 1 root root    18 2009-07-02 15:06 libbind9.so.50 -> libbind9.so.50.2.0
-rwxr-xr-x 1 root root 41808 2009-06-24 08:58 libbind9.so.50.0.3
root@prodigy:/usr/lib64#

After fixing this one by hand, too, host seems to run again.
Comment 4 Andrew McNabb 2009-07-02 17:19:32 EDT
Other than the broken library symlinks, the update seems to fix the original bug.
Comment 5 Adam Tkac 2009-07-03 05:01:15 EDT
Interesting, bind-libs in repositories is correct. Would it be possible to try `rpm -e --nodeps bind-libs`, `yum install bind-libs` and check if symlinks are correct, please?
Comment 6 Andrew McNabb 2009-07-03 10:24:47 EDT
After uninstalling and reinstalling bind-libs, the symlinks are correct.  That's very strange (I never touched the symlinks by hand).
Comment 7 Fedora Update System 2009-07-03 15:41:58 EDT
bind-dyndb-ldap-0.1.0-0.2.a1.fc11, dnsperf-1.0.1.0-10.fc11, bind-9.6.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.