Bug 507497 - compatibility issues with 2.6.29 kernel and some nvidia cards
compatibility issues with 2.6.29 kernel and some nvidia cards
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 21:03 EDT by Paul Paukstelis
Modified: 2010-06-28 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Paukstelis 2009-06-22 21:03:06 EDT
Description of problem:

Attempted DVD update of Fedora 10 system with nvidia 8600 GT. Could not get X to start no matter what drivers I tried to use. Tried a clean install, and anaconda would fail to start X. I was able to start X with vesa driver. Even doing a clean install would not get X to start with nouveau, only vesa. Tried to install nvidia drivers, but got the error message that the drivers were not compatible with the card (
http://www.nvnews.net/vbulletin/showthread.php?p=2034364&posted=1#post2034364)

There appears to be some issue with memory assignment that is preventing 2.6.29 from recognizing certain video card configurations. This was not an issue with 2.6.27. see http://www.nvnews.net/vbulletin/showthread.php?t=133129. This likely requires a kernel patch. I flashed my bios but still couldn't get it to work. Going back to Fedora 10 at this point.

Version-Release number of selected component (if applicable):
2.6.29 (from DVD iso)

How reproducible:
Very, for me.

Steps to Reproduce:
1. Install Fedora 11
2. X won't start
3. X won't start
  
Actual results:

No X, no video driver loading

Expected results:

Video driver load, X start
Additional info:
Comment 1 Chuck Ebbert 2009-06-29 12:15:10 EDT
Did you try the nv driver?
Comment 2 Paul Paukstelis 2009-06-29 13:24:21 EDT
Yes. I initially modified a basic xorg.conf manually to switch driver to nv. Nothing. Unfortunately, I wasn't saving logs after everything I tried (was getting irate). I've gone back to Fedora 10 at this point as I can't be without this machine. If you check the links from the nvidia forum, it is pretty clear that it isn't from their end.
Comment 3 Paul Paukstelis 2009-07-07 12:47:29 EDT
Update: I went ahead and installed 2.6.29.4-75 Fedora 10 packages from koji, and these seem to work fine.
Comment 4 Paul Paukstelis 2009-07-24 13:05:15 EDT
Update: after a yum update, the 2.6.29.4-75 kernel I installed stopped working. It gives me the same errors I was getting in dmesg previously. Namely that the nvidia driver is not compatible with my video card.
Comment 5 Bug Zapper 2010-04-27 11:11:03 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2010-06-28 09:14:21 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.