Bug 50754 - Both neat and internet-druid do not set a PPP interface as the default route
Both neat and internet-druid do not set a PPP interface as the default route
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 16:56 EDT by Panic
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 17:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-08-02 16:56:30 EDT
Description of Problem:

Both neat and internet-druid do not set a PPP interface to be the default
route by default.  This makes dialing out when you already have a default
gateway a futile exercise, since the machine can't go anywhere on the
dial-up connection (no route).  It also has no effect on a machine without
an existing default route, so it is a much better default.

How Reproducible:

Always

Steps to Reproduce:
1. Use internet-druid or neat to set up a dial-up interface.  Note that
"set this interface to be the default route" is in the Advanced options,
and is not selected by default.
2. Attempt to use this connection to dial out on a machine with an existing
default gateway.
3. 

Actual Results:

No traffic possible on dial-up interface, name resolution and network
traffic go undetermined (sometimes works, sometimes doesn't).

Expected Results:

Dial-up interface should be set to the default route while active by
default, to allow a network-connected PC to dial out to access a specific
remote network.  A dial-up connection should not remove the entries in
/etc/resolv.conf from a pre-existing connection by default. That assumes
that the local (network, not dial-up) DNS server has access to the
internet, so this should be a toggleable choice (it is, PEERDNS) which
defaults to Yes (for the majority who are dialing out normally).

Additional Information:
Comment 1 Ngo Than 2001-08-05 06:24:18 EDT
It's fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.