Bug 50756 - gettext > 0.10.35-31 needed to build from CVS
Summary: gettext > 0.10.35-31 needed to build from CVS
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 21:00 UTC by Nathan Owen
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 21:00:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan Owen 2001-08-02 21:00:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
The version of gettext in RHL7.1 (0.10.35-31) does not not define
@BUILD_INCLUDED_LIBINTL@ in gettext.m4, causing the build to fail in intl.

How reproducible:
Always

Steps to Reproduce:
1. ./autogen.sh
2. make

	

Additional info:

Build succeeds with latest gettext from rawhide (0.10.38-4). 

Maybe adding a gettext buildrequires or a copy of a good gettext.m4 to be
included in aclocal.m4 would be a good solution.

Comment 1 Jeff Johnson 2001-08-02 23:52:35 UTC
If you're building on Red Hat 7.1, or any linux, you don't need
to configure with --with-included-gettext.

If you're building on non-linux, then you will (may?) need
the same version of gettext, or will need to add --with-included-gettext.

There's no way at the moment to track this coherently with a build
dependency, as there are far too many platforms and versions of gettext
around to adress this problem logically.


Note You need to log in before you can comment on or make changes to this bug.