Bug 507571 - freeradius packages do not check for user/group existence
freeradius packages do not check for user/group existence
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freeradius (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 07:02 EDT by Alexander Todorov
Modified: 2009-09-29 10:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 536752 (view as bug list)
Environment:
Last Closed: 2009-06-23 16:45:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 07:02:55 EDT
Description of problem:
@everything installation yields lots of error messages about user/group radiusd not found. This is because these packages don't have scripts to check/add required user/group . Only freeradius alone has this script but it is installed later in the transaction.

A scriptlet needs to be addes and the packages should depend on shadow-utils which provides the useradd/groupadd commands and glibc-common which provides the getent command used in the scriptlet:

preinstall scriptlet (using /bin/sh):
getent group  radiusd >/dev/null || /usr/sbin/groupadd -r -g 95 radiusd
getent passwd radiusd >/dev/null || /usr/sbin/useradd  -r -g radiusd -u 95 -c "radiusd user" -s /sbin/nologin radiusd > /dev/null 2>&1
exit 0


Version-Release number of selected component (if applicable):
freeradius-devel-2.1.3-4.fc11.x86_64
freeradius-ldap-2.1.3-4.fc11.x86_64
freeradius-postgresql-2.1.3-4.fc11.x86_64
freeradius-mysql-2.1.3-4.fc11.x86_64
freeradius-krb5-2.1.3-4.fc11.x86_64


How reproducible:


Steps to Reproduce:
1. install @everything
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 John Dennis 2009-06-23 16:45:03 EDT
Thank you for the bug report. Fixed in: freeradius-2.1.6-3.fc12 which has been built into rawhide.
Comment 3 Fedora Update System 2009-09-15 11:54:28 EDT
freeradius-2.1.7-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/freeradius-2.1.7-1.fc11
Comment 4 Fedora Update System 2009-09-29 10:28:13 EDT
freeradius-2.1.7-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.