Bug 507575 - Problem With The Second DNS Server
Problem With The Second DNS Server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 07:11 EDT by Balogh Laszlo
Modified: 2009-06-24 04:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 04:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balogh Laszlo 2009-06-23 07:11:52 EDT
Description of problem:

I experience a problem with Fedora 10. The second DNS server doesnt work.
I assign the network options via DHCP but the problem is the same with 
static IP.

I assign two DNS servers. One for my internal network (first one), and one external, that handles the ex-lan DNS (second one). NetworkManager receives the data right (nm-tool shows this.), i get the DNS servers assigned OK. I can ping names on the lan and from the internet OK from command line. 
But neither firefox nor the graphical package manager is able to connect to any outside DNS. I repeat: i can ping them from command line.

Funny thing: if i reverse the dns servers, making the external DNS1 and the internal DNS2 then the traffic from the internet works fine, but internal websites don't work. I can ping them from command line at the same time.

Resolv.conf holds the two dns servers all right.

If i disable NetworkManager and enable network services, the problem stays the same.

IPv6init=no

Version-Release number of selected component (if applicable):
I sighted the problem only on Fedora 10 X86_64, i386 installed after 2009.05.30.
I have working fedora 10 servers with the same config  - working all fine(although i havent updated them).  

How reproducible:
I just install Fedora 10......
Comment 1 Balogh Laszlo 2009-06-24 04:52:42 EDT
Hi there!

Sorry, Yum update and yum upgrade solved it.

Note You need to log in before you can comment on or make changes to this bug.